Razer Blackwidow problem

so after waiting and listening to lies of the razer dealers in my country (sri lanka)for 3 FREAKING months!! i told one of my friends who was flying to Malaysia to bring the BW ultimate for me and when i got it yesterday i was so excited , he had already checked if it was DOA when he got it and it worked perfectly fine yesterday but then this morning when i switched on my desktop it said keyboard not responding or not present, i was like WTF? so i tried out plugging in to different ports but it still gave the same message then i tried using one of my spare keyboards and it works( im typing on it and its horrible)

later i tried plugging it in when windows was booted up and it said " device not recognized"

and yes i did remove the drivers reinstall it and did the whole driver update thingy but it still does the same thing..

so is the keyboard dead? or is it a driver issue that i can fix it myself?


check to see if there is a driver/firmware update and try unisntalling all related drivers and reinstall

how can i update the firmware when the keyboard is not even recognized by windows ?

Is your windows 7 up to date with all the updates?


Is your windows 7 up to date with all the updates?

yes it is but now i installed the firware update and when i plug in the BW it says razer bootloader plugged in what does that mean??

sorry for my nubness

Remove drivers and devices connected to the keyboard, unplug it, download the newest drivers online, install them, plug in. SHOULD work after that.

installing the drivers again with the new firware update installed let you guys know soon thanks!

well i guess im outta luck , when i i open up the driver software it says " No blackwidow ultimate connected " ... guess ill have to send it back to malaysia for RMA and hope it gets approved until then ill be on a 9$ keyboard .... dayum this feels very VERY cheap and clunky

just curious anyone on RTW have the BW ultimate?? if you have you had any issues with it??

hey guys so i went and bought another Blackwidow ultimate from the local dealers and this time the machine starts to boot from the freaking keyboard... i tried setting all the boot options to hard disks but when ever i restart the machine it automatically sets to boot via the keyboard so i have to plug in another keyboard and change the boot option every time i have to boot the PC with the BW plugged in any of you guys have had this issue?? please HELP!!! if this continues im seriously switching back to logitech

use razers tech support? although i doubt you will get any real help but its worth a try

Sounds like typical Razer to me. This is why I refuse to own anything of theirs ever again.

i haven't had this problem or any other problems with razer before but this is the first and its with the same type of product , i am going to try a BIOS update on my mobo and see

so, it works on other computers?

im typing on it now, it does work but the thing is the machine tries to boot up from the keyboard. this is a common issue with the blackwidow but they did release a firmware update to fix this but it didn't work for me. what i do is i ve plugged in another keyboard and go to the boot menu and set it to hard disk every time i boot into the machine... so yeah a real pain in the arse

hey guys thought of updating on the situation , the 2nd keyboard is working perfectly after a BIOS update but it seems that the blackwidows with the bootloader issues corrupts the BIOS (im not sure whether thats evern possible) so anyways with the new firmware update and the BIOS update i finally can get the blackwidow to work as a keyboard and not as a boot drive .

the keyboard is so far good im loving typing on the thing , hope this wont fail on me cause ive really got a liking to mechanical keyboards and i did feel uncomfortable using and cheap using a normal 10$ keyboard when the BW was outta commission

Unplug it and restart your computer while leaving it out.. I had to do this with multiple razer products.

Twitch said:

Unplug it and restart your computer while leaving it out.. I had to do this with multiple razer products.

the problem was sorted out with a BIOS update as i mentioned in my previous post :)

Hi, i'm actually having the same problem right now. what you said about BIOS and boot menu is confusing. I need help. It wont work anymore it says unknown device and sometime it says Razer boot loader. (when i unstall and plug it in again)