Raspberry Pi & x86 emulation, just confusion

Hello! Just like the title says I’m interested into running x86 application on my Raspberry Pi.
I’m really confused about it because the Pi doesen’t have that much resources to work with so I just can’t install Qemu and call it a day. Everyone on the internet uses Exagear but it’s a paid software and I don’t want to pay any “entrance ticket” to explore something out of curiosity (it’s not worth to me).
From the very few information I was able to find I need to install Qemu but, to avoid a massive performance penalty, I need to interface directly with the VM kernel. This should be enabled by chrooting into it but my knowledge about it is none. Can someone give me some indications or instruction to start from? Thanks a lot!

But no.

1 Like

This site uses Exagear, the paid software I was talking before.

This images are really really really outdated, 2015…

I’ve been on those sites already. Also I don’t think you saying no would tone down my curiosity

1 Like

Exagear is the only one that works in any sort of usable way.

Qemu, can be done, but you’re on your own on that one. People have given up on that with the Raspi.
Read the old threads and docs on that README of the github repo. There might be another one around.

I tried it once before and it’s just painful.

Here you are.

Have fun :smiley:


Qemu source may even need patching for RasPi and that patched source is probably woefully out of date by now.

Now we’re talking, this looks like a point to start my experiment. Thanks!
Do you have anything else about it? How did you give it a try?

I had exagear to test with since I own it anyway.

Qemu works, but don’t don’t expect too much. I mean you can run Windows XP on a raspberry Pi 3.
But anything further and the little ARM core has a seizure.

There isn’t much out there since x86 emulation on arm is a really niche area.

Oh okay. Well I just need something that works, I’m not going to run crazy things off of it. Also I’m not going to use any Windows application, just try out some Linux applications

P.S. to use Qemu I need to install an x86 OS VM or I just use Qemu on it’s own?

You can execute x86 directly without a vm via qemu-i386-static but the dependencies have to match properly too etc. So basically do it in a chroot.

These should approximately guide you.

I’m going to read it tomorrow, now headache is killing me. Thank you so much for all the informations!

This part is still not clear and reading through the threads you linked didn’t help me unfortunately.
I’m installing Ubuntu Server 16 LTS for now and so far is working but I don’t know how performances are going to be.

What I did understand is that qemu allows to execute 32 bit instructions on ARM CPUs translating them “on the fly”. But how do I install something and tell qemu to do that?

I haven’t used an x86 emulator since back in the days when Apple used PPC processors that was 5 years ago. Back then it wasn’t worth it because a high-end G5 Mac still gave an awful performance. But now I want to try it again with improved emulators for playing retro games once again, any suggestions for good GameCube Emulator if it works/

Thread closed as it was outside the guidelines for thread revival. Please PM me or another moderator if you feel the thread was closed in error. See the FAQ for more information.

Feel free to create a new thread if you wish to continue this thread’s conversation.