Return to Level1Techs.com

Raspberry PI connection issue

I apologize for the NOOB question. i should be better at this by now. I have a RPi 3+ connected to my home network on wifi. It has an IP address assigned by PfSense. I cannot ping the gateway, 192.168.1.1.

iproute shows:
default via 192.168.1.1 dev wlan0 proto dhcp scope src 192.168.1.174 metric 303
192.168.1.0/24 dev wlan0 proto dhcp scope link src 192.168.1.174 metric 303

I didn’t type any of this in.

The weird thing is that when I plug in an ethernet cable, everything works fine. I am flummoxed. It could be something PfSense is blocking but I cannot find anything and, as I said, the ethernet connection works fine.

I appreciate the help.

I’d try and delete the two entries with metric 303. Can’t say why, they just look out of place, never seen entries like that. If someone else knows what they are, I’d like to know too.

If you’re running raspbian, did you fully update your pi, with rpi-update and apt?

I haven’t tried the buster release of raspbian, baked my own 64bit Debian, so cannot say if they implemented netplan for network configuration, like Ubuntu did. That one I had issues with where it did some weird things with routing.

Thank for the reply. I did do an update. I had to do it with an ethernet cable but it went fine. Strangest thing was that I awoke and it worked. Then just now, I looked over and it is disconnected again. Bizarre. I have a Pi 4 running too and the exact same thing is happening. Come to think of it there are the only 2 pis in the house that are wifi. All others are wired.

Is the gateway definitely 1.1?

Unfortunately I have very limited experience with pi WiFi. Would rather have chronic diarrhoea than run over a WiFi on just about everything. If interested, I’ll be posting a guide to bake a 64 bit Debian arm image coming week, if I get the time for it.

It is.

I am beginning to wonder if it has something to do with my Ubiquiti access point. I made my mobile a hot spot and the pi connected immediately. I set up an open wifi channel and the pi will not connect to that either.

Could it be undervolted? WiFi uses a lot, maybe it’s not getting what it needs.

1 Like