Random reboots while editing the BIOS [Solved]

So recently I have been having an issue where my PC will randomly reboot while I am in the bios editing settings. This issue does not occur once I have booted into an operating system, it only occurs in the BIOS. I have tried flashing the latest BIOS update but the issue remains. I have not been able to find any information on similar issues online.

Motherboard: Gigabyte GA-F2A85X-D3H
CPU: AMD A10-5800K
GPU: Zotac Geforce GTX 1050ti 4gb
Ram: Corsair 2x 4gb
HDD: WD Black 1tb
SSD: Samsung evo 250gb
PSU: Corsair cx500

Any help would be appreciated. Let me know if you need more information.


So as it turned out it one of my stick of ram was bad. I don’t know why the problem wasn’t detected in Memtest (I ran Memtest over 12 hours) but upon replacing the bad memory they system has worked fine ever since. When I tried out the bad memory in another pc it displayed the same symptoms immediately so that was definitely the issue. Thanks to everyone for your help.

Thats because the bios is set up to reboot after specific settings. I have had many a foxconn board that does that. Theres nothing wrong with it.

I don't think that is it. The reboots can happen before I change any settings. Sometimes they happen seconds after entering the BIOS and sometimes it can be half an hour.

Wake sure the RTCReset jumper hasn't fallen off or something?

I believe the RTCReset jumper is supposed to stay off unless you want to clear the CMOS.

Most CMOS jumpers have three pins and two positions clear and normal so you will want to be sure that it is in the right place.

On my motherboard this is what the CMOS jumper looks like. It only has two pins and nothing is connected to it.

Clock battery is the right way around i assume. Did you try setting the BIOS to defaults?

I would think that flashing the latest bios would reset the settings, but can't hurt. Maybe try pulling the watch battery for a few minutes instead of using the jumpers, scare it into submission. You could try older versions of the bios as well, if the problem was introduced in an update.

Also, how long have you had this board for? If it's new, it might just be bad, though I'd put less money on that if it's worked for a while without this problem.

I bought the board in 2013 so it is getting kinda old. This problem has been present in previous bios versions so I don't think an older bios version is going to do anything. I have already tried removing the battery and using the jumpers. Perhaps the board is just going bad? If I save my settings before the reboot they get applied and survive reboots. It's not really that big of a deal tbh just kinda annoying and mystifying.

Yeah, it always sucks when the mobo goes bad because you can never be sure. But it's the only part that might behave differently in bios versus an OS (unless your PSU only works properly under high load? But even then sleep mode should cause problems). I don't know if this means the whole board is on its way out or not, but maybe think about getting a new board if you really depend on the pc. If you have a laptop or something as backup and don't want to upgrade right now, maybe just take your chances and let it go as long as it lasts. If that's what you do, best of luck.

Have you tested your RAM by chance?

use memtest+86

Just tried that. There were no problems detected.

Yea, guess I'll just live with it until I can afford and upgrade or it breaks.