Return to

Ran apt-get update, now computer won't POST



Was running apt-get update, not paying a whole lot of attention but I’m assuming updating the proprietary nvidia drivers caused the promt to ‘disable secure boot’. Fine by me, so I continue, it asked to provide a password that to enter upon reboot. I reboot. Boom, computer won’t POST.

So I flip the dual BIOS switch to into the backup BIOS. Computer is able to POST, loads the original factory BIOS setting, and boots directly into Windows, the default boot loader for that BIOS (usually I boot into GRUB). I also go into BIOS and disable secure boot but I cannot recall if I was able to succesfully boot afterwards.

Figured it was time to clear the CMOS, and since the battery was dead, replace that while I’m at it. I changed the battery and put the jumper to clear the CMOS. Afterwhich, neither BIOS A or BIOS B will POST.

Trying to diagnose the issue but I’m drawing blanks. My guess is the culprit was that the ‘disable secure boot’ crap somehow fucked up my BIOS but I figured clearing the CMOS would resolve the issue, instead it seems to have exasperated the situation.

Since the computer was able to boot into Windows from the other BIOS configuration I don’t suspect hardware malfunction to be the culprit, except potentially having damaged the motherboard and maybe other components while clearing the CMOS.

I don’t have a motherboard speaker but I’ve ordered one to see if it can help me diagnose the problem.

Don’t have another X99 system where I can test the CPU or RAM.

Here’s what I’ve tried so far:

  • Removing all peripherals besides CPU, RAM and switching to a basic GPU I have laying around with VGA.
  • Trying using only one RAM stick, in different slots.
  • Removing the CMOS battery and leaving in the jumper over night.


  • The BIOS LEDs both light up for BIOS A, but only BIOS B for BIOS B
  • Sometimes the CPU fan won’t spin up, other times it will. Haven’t been able to reproduce a procedure for when it does and when it doesn’t.
  • One time I was able to get a blank VGA signal, ie. the monitor was blank but without the ‘no-signal’ prompt.

Any suggestions or input on how to diagnose this further?


  • MSI x99s
  • 5820k
  • 2x8GB Corsair DDR4
  • MSI 1080ti
  • Corsair RM850 850W
  • Ubuntu 16.04
  • Windows 10

I’m not Wendel, but I’m signing out


Looks like to switch back and forth between BIOS A and B, you need to flip a physical switch. You say you’ve reset the BIOS by using the jumper, but I’m wondering if that only resets the BIOS that you currently have selected. If you haven’t already, can you set the switch to BIOS A, and then connect the jumper to reset the BIOS? Do not remove the battery for this, specifically keep the battery connected.

This one strikes me as odd. For funsies, you might try resetting your PSU. I don’t know if resetting is the right term, but that’s the best I can come up with. Unplug the PSU from the wall, hit the power button to drain it, (assuming you’re in the US) flip the red voltage switch on the back from 115 to 220, give it a sec, switch it back, plug it in, turn it on.


Could you try removing the CPU and see what happens. Worst case would be to do a bios flash with a USB drive if you mobo supports that.

It is possible the Ubuntu nuked the EFI firmware or at least the EFI bootloader.


I tried flashing to the latest BIOS following these instructions, basically insert USB with BIOS, boot and pray. I wasn’t able to get into any flash BIOS menu but now BIOS A only lights up the BIOS A LED, spins up CPU fan and outputs black VGA signal (with a tiny flicker at one point). The CPU is generating a little heat, not a lot but the CPU fan airflow is slightly above room temp.

Without CPU there’s no CPU fan power and no video signal. I should be getting my motherboard speaker in the next few days, hoping that can help me diagnose better.

This literally happened two fucking days and three years after purchase, so I’m not sure I can claim warranty :expressionless::gun: Might try a replacement BIOS chip as next step.



You may to well by getting a new or used mobo at this point since bios chips can run north of 30USD.

I am sorry that you are experiencing this issue. I would recommend running anything but Ubuntu in the future as some of their stuff is not as well tested on a wide variety of hardware as other distros.

I say this as having used Debian (unstable/SID) since 99 and arch since 2006.


Have you made an emergency flash drive Linux distro in which you can boot into to see if you can see your other installation? Doesn’t sound like failed hdd or hardware since you can boot into Windows… So perhaps a flag was not right on your apt update and it messed with the GRUB.


x99 motherboard run at around €200 and there is virtually no secondhand market where I live so getting a chip for $15 isn’t a bad deal, especially if HW is fine. If I need to replace the mobo I might as well just invest in a Zen platform.

Mainly running Ubuntu because I understand it has the best GPU and compute stack compatibility but I plan on playing around with other distros. Haven’t been running Linux for very long.

Got my mobo speaker in the mail today so I’m going to plug that in when I get home and diagnose a bit further.


I was able to boot into Windows but now neither BIOS will POST so can’t really boot into anything at this point :frowning:


Ouch… Sorry dude :frowning:


quick thought, you can clear the cmos with a screwdriver. you are just shorting the pins. put the jumper back to its original position. with the jumper in clear position at boot you may be telling it to constantly reset. not goot. idk just a thought…

how is your dual boot set up? same drive?


Not sure I follow. This model only has a two pin for clear CMOS. The jumper can only be in the clear position, otherwise it’s off.

Dual boot on same drive, yes, but right now I’m focused on getting past POST.

I got the motherboard speaker today. Was giving me a long followed by two short beeps on BIOS A. No beep codes in the manual, very little information out there regarding beep codes for CLICK BIOS but gathering from this it means

An error was encountered in the video BIOS ROM, or a horizontal retrace failure has been encountered

whatever that means. Confirmed GPU worked in another computer. Tried flashing BIOS from the USB again to no avail and now no longer get POST codes, presumably because it’s stuck in POST.

Haven’t tried @Levitance suggestion on resetting PSU yet. Haven’t seen any 110-230v switch, maybe because I live in the United States of Europe


On occasion here in the US there will be a PSU that doesn’t have a switch on it. I had just assumed the switch made it easy for PSU manufacturers to make 1 PSU model that could be sold in the US or Europe. I could be mistooken, though.


I think I’ve seen one of those switches but doesn’t look like this model has one. Too bad. It would’ve been nice to try your somewhat esoteric suggestion.


You can still pull the power cable and then use the power button on the mobo to fully discharge the PSU.

Did you look to see if there were bent pins in the socket? Unlikely but worth a check since you were moving things around.

I guess a flashed BIOS/UEFI chip is in order. Sounds like something borked at a low level.


I’ve pulled the cable and discharged the PSU at least a few dozen times at this point.

Shouldn’t I get a different POST error if the socket was borked? Pins looked fine when I removed the CPU. I will try that again this weekend now that I have the speaker to verify I get the appropriate POST error w/o CPU.

At this point I think it’s either corrupt BIOS/UEFI or the motherboard has been borked somehow with all my fiddling around in it.

Anybody have any experience to share regarding soldering a BIOS chip?


I recommend that if you are going to solder it, find the appropriate socked so that you can swap the chips easily. Solder once and swap often if need be.

I would also recommend possibly filing a bug report with Ubuntu to see if this is a unique issue or if it is already documented. I know that there is an RS232 port on the mobo. You may be able to debug with it. I am sure many a UEFI was borked during the testing of Ubuntu’s packaging and testing of their EFI tools.


Hey Man_sacababo - any updates yet?


Waiting for my replacement BIOS chip…


Any good source for this or just ebay?


This site from Germany, they also have an Ebay store.

I also came across but their shipping cost was like twice the price of the chip + shipping from Germany, although they did carry a SOIC8 socket. I’m going to see with them if they have other shipping options because their shipping rate was just outrageous.