RAM Issue or Board?


So, after recently building my Ryzen PC and booting up, I had an issue with my RAM it seems. Although, I am unsure if it’s the board or one of the RAM sticks, for example, in the board manual page (posted below) it mentions for a single module, connect it in DIMM A2 and for 2 sticks, DIMM B2 and DIMM A2.


1x 8GB RAM stick in DIMM A2, booting up, LED indicator blinks orange (for RAM) then red (for CPU) and then white (for VGA)

Stick both 8GB RAM modules in DIMM B2 and A2, LED indicator is orange and PC won’t boot.

Board Manual DIMM section: imgur[dot]com/a/V2oHuJQ (I can’t post links)


RAM used: 2x 8GB G.Skill TridentZ 3200 Mhz (F43200 C16D-16GTZR) 2018 Aug

  • I looked on the motherboard supported RAM list and my RAM is on there.

Board: Asus TUF Gaming x570 Plus

CPU Ryzen 3900X

Does anyone have an idea? I think its one of the memory modules?


Sorry to hear your troubles,

Have you tried each stick in A2 (one stick at the time) for single stick operation?

If both sticks operates, move to two sticks and swap their location around, also they the invert options in case you have got it the wrong way around (unlikely but… :wink:, we have all been there )

Obviously if the second part fails it is definitely the board (RMA)

Good luck

In the A2 slot I managed to get one stick working. But when attempting to test the other stick it fails to boot, so its likely the RAM stick, it worked a couple of months ago which is what I don’t get.

Sorry to hear mate,

I have had a few different parts not work on my latest build

It’s like quality testing isn’t that great

I hope you get it sorted and up and running ASAP

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.