RAM Errors?

If I run Memtest86 on either stick alone it’s OK.

If I run Memtest86 with both sticks it’s many errors with or without XMP…

Does this point to a RAM problem or Memory Controller?

Is the Memory Controller on the MB or CPU?

PC has been running fine all stock until the recent Memory blue screen.

3700x

MSI MPG B550i Gaming Edge Max WIFI

G.Skill Trident Z Neo 32GB (2x16) DDR4-3600 CL16

Controller.

1 Like

… CPU

2 Likes

Could always dig though some settings, maybe try a BIOS update for the hell of it, before you likely accept you need to RMA the CPU or pay for a new one.
Did you try each of them in the same slot? Could be other channel of controller, or the board has a problem with that slot.
Suppose you may have made the mistake of putting them on same channel, but at JDEC spec speeds, should be fine.

I’ll try a BIOS update, thanks.

Do you have another pair of DDR4 RAM sticks you can try testing with? I agree that this sounds less like a memory issue and more like a CPU or mobo issue if each stick tests fine individually, which means you should be able to recreate the same issue on that hardware with another set of known good RAM.

I just put the two “bad” sticks in another PC that just passed Memtest and it shows the two sticks as bad on the second PC.
Back to looking like the RAM.
I will try one stick on the second PC now.

It might be worth trying manually setting the RAM speed in the BIOS. It’s a bit of a long shot but the ECC RAM installed in my server motherboard throws errors when running at stock clocks, when the speed is left as auto. I don’t get any such errors if I manually set the speed though [EDIT] to the speed it’s meant to be at “auto”.

2 Likes

The RAM is giving the same errors in two PCs.
Good RAM in the problem machine shows no errors.
Going to RMA.
Thanks for the help.

1 Like

run ryzen timing checkers

with dram calc you will need to look up the IC (the chip) on the pcb.
you enter it and the speed you want to run at and it will spit out both safe and optimized settings.

take all the timings and settings on the first page and enter them into your mem timings manually.

you should with luch have stabile timings.

i used this myself as i was constantly getting random memory errors. end result was bad data being written to my o.s and after a few weeks bsod central would be apt…
anyways after running the above i got sweet timings that showed zero errors and i haven’t needed to do a scannow repair since.

try re-seating the cpu?
Sounds silly to pull it out and just put it back in, but worth a shot.