Radeon VII vfio woes

Hi all,

I’ve recently swapped out my secondary GPU (RX590) for a Radeon VII. So I now have a 5700XT and a Radeon VII in my box.

I’ve setup the vfio bits the same as I had for the RX590 but now for the Radeon VII but whenever I try to boot any VM on the Radeon VII the GPU doesn’t seem to initialize. I have checked the firmware on the VII and it is the latest so it’s not the UEFI issue I think.

I’ve tried both with Linux and Windows guests, tried updating the AMD drivers on the Windows guest as well. The gpu shows up in the hardware information but says that the device had to be stopped due to hardware issues.

Is there anything else for the VII I need to do to get it to work with vfio? Alternatively I can swap the GPUs and use the 5700XT as secondary, I was kind of planning to do that anyway but now the fact that I can’t get the VII to work is bothering me.


  • HP

@gnif is working on this, but it looks like the VFIO issues might be driver dependent on specific versions of AMD drivers. The latest one might not work.

Thanks, but I don’t think that’s the issue. I tried the very latest Linux kernels and the very latest Win10 drivers. There’s something else messed up I think.

The VII refuses to reset and all known methods that work for Navi cause the VII to completely hang. You must make sure the VII is not posted at boot and is not initialized by the host to get it to work in the guest.

1 Like

OK, thanks a lot for the information. I’ll just switch the VII back to the primary slot then and use the 5700XT as my pass-through card. <3

Yes. Try to compile kernel without DCN2 options.