R9 280X GPU Usage Issues

Hey Y'all! I just want to start with I love the community here, I've read lots and watched lots without ever posting myself. But alas, I've stumbled upon an issue I can't quite figure out how to solve.

So, I build and sell PCs for money on the side. Whether it's for a friend or just any ole random person, I try to make a decent PC for the money. My most recent idea was an athlon x4 750k based gaming computer. I know the athlon isn't the best 'gaming' cpu, but having seen the reviews, benchmarks and videos, I went ahead with it. Seeing as I mostly play BF3/4 I saw no reason to go with this as the frostbite engine is mostly GPU intensive (And BF4 is supposed to have special AMD gpu utilization or w/e) Now, since I spent nearly nothing on the mobo/cpu (I did the same setup that Logan suggested in one of his recent kill your console vids), I was able to budget A LOT more towards the gpu. So I went ahead and purchased the 'new' gigabyte r9 280x. This thing screams. On BF3 (64 player) at preset ultra at 1080p, I'm normally getting 60 fps stable with vsync on, 60-100 with vsync off). So that's great. But for whatever reason, I decided I wanted to install MSI Afterburner to monitor temps. Well the temps are very very cool; never passing 65, which is again nice. The problem is, for whatever reason, ever since I've installed MSI afterburner, the GPU REFUSES to go past 25-30% usage. As you can imagine this means I'm now getting max 30fps. So I've read everywhere, I've tried almost anything (with what little time I've got). I've read left and right that people with similar builds (using a 7970, not r9 280x) are having the same problem. Most people immediately say "CPU [email protected]#@[email protected]#" but I can assure you, this isn't the case. I don't understand how it COULD be the case considering the computer was running stable for two days until I installed afterburner.

 

Before continuing I should give you a list of my specs and drivers.

CPU-Athlon x4 [email protected]

GPU-Gigabyte R9 280x @ 1050mhz 3gb gddr5

MOBO-MSI a75m fm2 (whatever Logan recommended)

CPU Cooler-Hyper 212 EVO with antec formula 5 paste (runs cool as can be)

PSU- Rosewill HIve 600w (80+Bronze on one solid 12v rail)

SSD-Kingston HyperX 3k 120gb

HDD-WD Blue 1tb

RAM-Gskill Ares 1600mhz 8-8-8-28

Case-Fractal Define Mini

GPU Driver-The most recent (and apparently only R9) beta driver.

 

 

So this is the part where I tell you what I've done to attempt to fix this issue.

I've reinstalled all the drivers. I mean ALL, mobo, cpu, peripherals, gpu, you name it. (although I've not yet gotten an older driver because I'm not sure if they work with the r9 even though it's just a 7970)

I uninstalled MSI Afterburner/Reinstalled it

I've flashed the bios.(mobo)

I've OC'd the CPU

I've underclocked the CPU

I've reinstalled my games.

I've lowered the detail to see if this issue will fix but for WHATEVER REASON IT STAYS AT 35FPS. I read online that people say if you lower the detail and resolution and still get seriously low gpu usage, then it's your cpu holding you back. So I went ahead and did 720p at low settings. The gpu usage maxed at 15% and the Fps stayed at 35ish. BUT, during this whole ordeal the cpu usage was only at like 60%. I should mention that at ultra, 1080p, the cpu is at about 85% usage. I understand that's on the high side, but wouldn't it be 100% if it was pure CPU bottlenecking?

 

I've tried a few other things which I can't recall right now. I'm currently on campus between classes and had to ask y'all for help because this issue has been plaguing me for a few  days now. I just don't believe the cpu could be the problem considering it worked 100% fine before all this. Also, I've seen builds online where people use this same build but with say an HD7850 and it works perfectly. Do you think this could be driver problems? After all I am using beta drivers because they're the only given ones on Radeon's site which suppport the r9 line. Any help would be much appreciated.

 

Thanks,

Marcus

 

P.S. I should mention that the only other game I've played on the rig was DOTA 2. DOTA Maxed out at 1080p was getting 80fps, but again the gpu usage never really went above 40%. I know that's an easier title so perhaps the GPU see's no need to go higher? When I get home I'll try to fire up Bioshock Infinite and Metro 2033 to see if they get the GPU running aswell.

you can use the drivers for 7900 cards that is what i am useing.

http://support.amd.com/en-us/download/desktop?os=Windows%207%20-%2064

also you should try to configure the settings within your games and see what happens

I just got home, gonna give those drivers a try and report back.

So I just ran the Bioshock Infinite benchmark tool and the same issue ensued. Only 40% usage max and I had the CPU usage up on the other monitor, it was only at 70%. About to scrap these drivers then dl the 7*** ones and report back.

Okay Doomed, I used the driver you linked me too and it SEEMED to help. I ran the Bioshock benchmark with CPU and GPU usage displayed. The GPU usage went p from like 20-40 to 50 ish and it peaked at 99 ONCE and when it was briefly at 99 I was getting over 120fps. But sadly it stayed between 20-50 mostly. During this my CPU usage was only 64%. So I decided to test BF3 again and sadly the results are similar. Rather than locked at 25% usage and 30fps, the gpu managed to maintain about 45% usage with again only about 50fps (dips around 30). During the BF3 test, the CPU peaked at 81%. I'm so dumbfounded guys. I am beginning to thoroughly regret this purchase!!!!

what psu are you useing? are all power connectors for the video card plugged in? everything else as it should be?

Rosewill hive 600w, yes everything is plugged in. I just downloaded and ran uniengine heaven and ran it fine. The gpu was constantly at 80+% usage which was nice to see. Was in the 40fps range on preset ultra which was nice. So I know the gpu works, I just can't get it to work at higher than 50% usage other than in benchmarks 

is v sync on?

Your cpu is bottlenecking

i agree, it's still the weakest link. are you monitoring your cpu usage? it's probably at 100%.

 

Vsync is on but it's not even getting to 60fps so that's not the issue. And don't just come in here and say CPU is bottlenecking! I just scored within 5% of the standard with uningine heaven extreme. this CPU is doing fine, but something is keeping the gpu from firing up in game. Why do so many people with 7970s/280xs have this issue? Do they all have CPU bottlenecks? Even the ones who experience this with i7s???

In a perfect world it would be, but generally not the case, for a game like this 70% cpu usage indicates a bottleneck, its very game dependent on what cpu usage indicates a bottleneck.

 

If you would read my whole post you'd see that no, CPU usage never passes 80. 60 in bioshock and 40 in unigine.

And WHY then do so many people have smooth 60+ fps gameplays in bf3 with the same proc...

ok sorry, but that cpu is really old and it wasnt very good to begin with.

Really old!? It's less than a year old ffs!

are your benchmark scores really low too?

Hello!

I would recommend downloading this GPU benchmark tool: Valley Benchmark real-time 3D engine http://unigine.com/products/valley/

Its gonna stress test you'r GPU to full 100% so you can see whats causing the problem.

Cheers!

lol in computer years?