Return to Level1Techs.com

PXE booting on an older machine: "File not found" with Yukon PXE. Other systems work fine but this one does not?


#1

Another issue with PXE booting that has confused me.

I’m now trying to boot a much older machine (AMD Phenom II X4 CPU) to PXE, and it has the feature. However, it says “PXE-T01: File not Found”.

I’m booting newer HP Laptops and Desktops just fine with the same setup. Newer here means 2012-2014 models.

Every device that’s worked has been an Intel CPU however. This means the PXE specifically says “Intel” on it, or in the case of some laptops, “HP”, while for this older machine that’s an AMD, it says “Yukon” which I imagine is the manufacturer.

Research suggests that the PXE is not interpreting the DHCP options correctly.

I’ve found threads talking about routing hardware adding characters to the filename for PXE booting, such as here: https://community.ubnt.com/t5/UniFi-Routing-Switching/Network-Boot-adding-characters-to-file-name/td-p/2215368

But it works for most devices and just not this older one, so that’s not likey to be it.


#2

Hey.
How does your PXE DHCP options look like right now?
Any tracelogs to share?
Whats the NIC on it trying to perform the PXE-portion?

Edit (clicked too soon…) -
Is your DHCP option 253 set correctly as you yourself are partially stating with the interpretation-portion (I know, it should be, since you are able to boot the rest).

From my sleepless state, I am not sure about the older Phenom being the culprit here - check out the NIC and check if there is any weird parts with PXE.

Edit AGAIN: I am unsure where I got the DHCP option 253 from!
Refreshing my brain after some sleep -

The options I was after;
60 Vendor class identifier Minimum of 1 octet
61 Client-identifier Minimum of 2 octets
66 TFTP server name Minimum of 1 octet
67 Bootfile name Minimum of 1 octet


#3

I’ve had some weird issues with PXE with Surface Pros specifically (SP3 and 4) - whereas the HPs we run just work.

In my case it is to do with the PXE server being on a different VLAN (that it should be able to route to - as the PXE implementation in the HPs do).

Unrelated to your issue, but my point is that not all PXE implementations are created equal, and some are just weird and buggy garbage.

If that’s the case, on a machine that old, you may just be boned and need to install from media.


#4

Maybe a shorter filename or a filename in root of the tftp tree or changing upper case to lower case filename or vice versa will help.

Look at how tftp requests differ using Wireshark, it might give you a clue.

Consider chain loading pxe environments, e.g. you may want to configure DHCP to serve gpxelinux by default and store more complicated configuration in its config files, or setup DHCP to serve a different filename if the clientid is gpxe.


#5

Right now, on a Cisco 1941, we have option 66 set and no others.
Tracelogs like with Wireshark or in Event Viewer?
I think Realtek. Let me check. It is a Marvell Yukon Gigabit Ethernet Adapter.

I’ve yet to see anything mention DHCP option 253. Based on this, that might be specific to a manufacturer’s routers?

https://www.iana.org/assignments/bootp-dhcp-parameters/bootp-dhcp-parameters.xhtml#options

224-254 Reserved (Private Use)

That’d make sense.

I’m actually already doing this. I’m using Windows Deployment Server to load PXELinux which can load the WDS PXE or Linux ISOs.

It doesn’t get to the PXELinux menu though as it just says “File not Found”.

I would but I’m not very experienced with using it to snoop on traffic that’s not coming or going to my main machine (where it’d be running). Can’t really setup mirror ports either. :expressionless:


#6

I found this TechNet article that may point to my issue:

https://social.technet.microsoft.com/Forums/en-US/e8498152-c9df-4201-8531-fa54baf69d00/problem-with-deployment-os-to-some-hp-computers?forum=configmgrgeneral


#7

I suspect that’s similar to the issue i saw with the SP3/SP4 machines. I forget the specifics, but the problem raised its head when we tried to retire a VLAN specifically set up for PXE boot OS installs, so i just didn’t retire the VLAN. I didn’t bother looking into it too much because in my case I had a work around.

Good luck, but kinda reinforces my idea that various PXE implementations are broken. Maybe a different BIOS may fix it. Just not sure if PXE lives in BIOS or primarily in the NIC firmware, which could also be something to try and update if possible.