PSU probably blew up :(

Okay so a few days ago my GPU (EVGA GTX 660) started to play up, I was in game playing SimCity5 (hey comon it's a good game!) and boom my game crashes and windwos pops up an error "Display driver stopped responding & has recovered" I didn't do any hardware or software changes and considering running EA's catastrophe I thought it might be a one off. So later on I start SimCity up again and this time micrsoft greets me with a BSoD again relating to the GPU. I reboot and try to run 3DMark11 and again the system crashes with a white screen not even a BSoD this time! Then I started up EVGA's OC Scanner and tried to do a benchmark, this time I got a black screen but the system did reboot, tried this multiple times but on the 3rd try it worked fine (Even disabled all non microsoft services the 2nd time in msconfig but looks like it wasn't a software issue). I went to Nvidia's webstie and realised new drivers were out, uninstalled the old ones and still has a problem. Up on contacting EVGA I was told this was a TDR (Timeout Detection & Recovery) service issue, I read the forum post on EVGA's webstie and this mentioned that the TDR issue can be caused by a problematic PSU, however there were about 10 different possibilites listed. So considering it a GPU issue at the time I ran off my integrated graphics and the problem didn't occur. However EVGA mentioned that I reinstall drivers while in SafeMode which I did and there wasn't any problem for a day. Now i'm watching a Youtube video and my system decides to turn off  without any warning. I took out the GPU and tried to start the system however when pressing the I/O button the PSU fan just spun up and then stopped this kept on happeneing every 5 - 10 seconds untill I unplugged the thing out from the power socket. My PSU has a dynamic fan which only spins when exceeding a temperature threshold, but in this case the LED on my PSU was also restarting and the LED on my WiFi card was also switching on and off which most likely means either my PSU's gone bad or my motherboard. I've contacted EVGA and Corsair but Corsair still hasn't responded, anyhow here are the System Specs:

Corsair GX600 600W


GTX 660 SC Sig2

MSi G43-Z77a

Corsair Vengeance 8gb 1600MHz

x4 Corsasir fans (120mm) overkill maybe? (Doubt any of these put a strain on the PSU) 

Gigabyte GC-WB150 WiFi card PCIe

Samsung 840 1SSD/ WD HDD 640GB


Now the damn thing won't boot up, just does that cycling thing and I don't know if it's the mobo or PSU, but considering a few days ago my GPU was having the above mentioned issue it's possible the PSU couldn't supply enough power to it hence why it crashed while running fairly intensive programs? And now maybe the PSUs blow a cap? and thanks for reading guys


Could be several things, but first off you should find a friend who has a PSU that can feed the system(350W-400W should be enough to boot this system).


hey I can open up my stock HP computer and use that PSU. BUt it is a STOCK "cheap ass" pile of junk just hoping my CPU or mobo aren't fried! 

If it has warranty, then return it to the store, if not, then you can open it up.

opened the HP pc and conected my Corsair PSU to the motherboard in that. The PSU works but when I connected it back to my custom build the same issue, I take it the mobo's dead? omg what if the cpu's fried! and btw my power switched tripped when I tried to put the custom build on, that is BAD...

Have you tried clearing CMOS?, you can do it by jumper or by removing battery and power.

Also the capacitors on the PSU might be dieing, or some other components, it doesen't exhaust full power, but somehow I doubt it's the PSU.

How are the capacitors on the motherboard?

Also you could try disconnecting components and connecting them again, also trying to boot with minimum  amount of components, no hdd, optical, no extra fans etc.

Also you can try booting with 1 memory.

Sorry if I'm not giving good advice, I'm not that sober.

Don't mess with it any further. I had a 600w OCZ ModXStream Pro fry itself and my motherboard on me recently after trying to hook up a 7970.

Similar symptoms. My trusty 6870 had started crashing, and I thought it was on its way out, so I put a spare 7970 in it. Booted up, bluescreen. Hooked my 6870 back up, no bluescreen but a crash not too long after it.

Stopped booting altogether. Light on, fan cycle, power off. Short circuit protection. Tore everything down, cleaned everything, reset BIOS, turned the system on with nothing connected but the memory and processor. Voltages showed up as okay in BIOS.

Decide to hook hardware back up one bit at a time. Hook up the 6870, short circuit again. Take PSU out and apart, blow everything out gently and brush the little nooks I couldn't get otherwise. Reassembled, PSU, hooked back up to motherboard with the GPU disconnected. Reset BIOS again, posted fine. Hooked GPU back up, posted fine again.

Power it off and start hooking the drives back up one-by-one. After 2 drives were hooked up, next power cycle failed, circuit protection again. Getting ready to hit the power switch on the PSU to cut the circuit so I can disconnect the drives again.


Pulled power cord, got extinguisher ready more smoke.

Pulled the GPU out and looked at the card, everything was fine. Looked at the motherboard. Voltage regulators under the GPU were toast.

Tried everything but the power supply in different machines and everything worked flawlessly.

Bought a temporary power supply and motherboard for now(this is just my bedroom machine anyway).

Just be careful.

yep it's defenitly the motherboard. I think my PSU truns off due to a protection feature as I hooked it up to my other computer and it worked fine which only leaves me to one culprit the motherboard. Contacted MSI via email but will most likely phone them tomorrow to speed things up.... Should've brought an ASUS/Gigabyte mobo -_-

Just want to update that I reset the CMOS and it booted so no fried CPU however I'm still sceptical about this issue as it randomly hit me after 2 months of running my system without any hiccups. I can guarantee that no OC was done and before this issue I did reset my BIOS arrggh I still don't have a clue as to why it's playing up... oh well only time will tell if the problems been resolved or not