Return to Level1Techs.com

PSA: testing for and solving random freezes on Ryzen

#7

As you say manufacturers, I would like at least 2 different manufacturers statements about the issue.

Ehm… my old Samsung Notebook can freeze and recover a minute later, then the age old AMD-GPU driver says “recovered after error”

Except people may not be as wrong as you like them to be.

0 Likes

#9

This is the second thread I have seen where you completely disregarded all given information and proclaim faulty mother boards with no evidence.

It may have been a problem for you, you are not everyone. You also state this is an idle problem, where the OP literally states “Stress Test” which cycles between idle, single core load and all core load so you cannot possibly put it down to idle problems with out considering the other two.

I have no problem with you providing information and helping out but blindly shouting the same thing will get you no where.

Edit: insulting people is also not helpful to anyone.

And do you mean a shop called Gigabyte, or the company gigabyte because as far as I know they do not have physical stores.

1 Like

#10

Lmao. So you deleted my entire post consisting of all the evidence I provided because of some insults and now you say I provided no evidence? HAHAHA… level 1 tech forum for sure.

Yes Gigabyte has physical stores in many Asian countries and they handle RMA directly. and even Asrock has this problem.

Did you read what OP actually wrote??

I’ll quote him: "This should be set to Typical Current Idle. The default/auto setting seems to be Low Current Idle, that saves an additional couple of watts when completely idle, but also seems to cause some sort of power glitching, that results in occasional freezes. From what I can tell, this setting disables Package C6 state, while leaving all other power saving features such as Core C6 state enabled (you may have to update your UEFI for this setting to appear, for the x370 Taichi I would recommend UEFI version 4.40, the later versions may or may not have regressions)

The problem OP is having is the same as idle crash. Jeez people just do a google search!!! ASROCK has this problem. lemme do it for you : http://bfy.tw/L6LR

I’m just stating that future people who have crashes in idle with ryzen should just go and RMA their boards. There can’t be any other cause for crashes at idle except faulty mobo.

Proof 1: Guy in your own forum confirms it : [SOLVED] Ryzen build freezing, can't find the problem

Proof 2 : https://www.google.com/search?q=ryzen+idle+crash

Proof 3 Asrock : https://www.google.com/search?ei=ge__W9fhNNe89QOi_aDQDw&q=ryzen+idle+crash+“Asrock”&oq=ryzen+idle+crash+“Asrock”

P.S. : IF ANYBODY IS HAVING RYZEN IDLE CRASHES THEN ITS YOUR MOBO AT FAULT. SAVE YOUR TIME. THANKS.

0 Likes

#11

Completely unrelated to this problem. Seems you just want to comeback with bad knowledge.

Read my reply above. Your tool is useless.

0 Likes

#12

It really isn’t always a defective motherboard. If you have an asrock ab350m pro4 then yes, it’s probably the motherboard. but there are freezing issues that can be resolved with some settings changes and updates. My dad’s 2400g was having issues until I updated the bios, set the recommended change in the op, and updated the video drivers.

0 Likes

#13

It is always a faulty motherboard if it crashes on idle at default settings. The issue isn’t limited to ab350m but a lot of Asrock b350,x370,asus b350 prime and gigabyte b450 ds3h. The power supply idle control is just a workaround which doesn’t work 80% of the time for most people. just check google. I can’t spoon feed you guys anymore.

0 Likes

#14
  1. Google searches are not sources
  2. half the results point to gear down or C-state problems, not mobo problems and no reason to RMA anything

What does this relate to?

0 Likes

#15

Firstly i deleted that said post, because of your insults towards other users.
Which in my opinion isnt really nice or needed.
¨If¨ you’re not sure how to discuss or argue on the internet in a polité way,
then you might wanne check out this post that wendell wrote.

https://forum.level1techs.com/t/how-to-argue-on-the-internet/85594

Ontopic:

You claim that its a faulty board with some articles about certain issues.
Which is a good thing, and you might be right.
However you can’t say for sure, because there are gazillion other possibilities that,
could be the root cause of the issue.

4 Likes

#16

I will accept that apology any time you like.

0 Likes

#17

@Zibob and @SamX

Lets take that to a pm if needed, to keep this topic clean.

Thanks :slight_smile:

1 Like

#18

I would add at least one crash at idle for me on Ryzen was on a Linux box with a bad power supply. Actually the power supply was totally fine but not designed for low idle current.

It was resolved with a bios update that offered a “typical” standby current option. This increased power draw by 5 watts. It took a few months to work this out tho. I disabled c states and manually set the speed and voltage before the bios updates as a work around

The typical current at idle is still a non default option, though. Weirdly. So a few users here have reported crashes fixed after this. One guy I helped said that this only happened about every 3 days, interestingly.

I have read reports of some asrock boards having a buggy fix … a kill a watt for measuring current usage helps for making sure you are actually getting higher power usage at idle. It’s easy to spot with a kill a watt.

7 Likes

#19

Ryzen idle crash is always a motherboard problem. Period. There are no other possibilities. I have researched for a month when it happened to me and the only way people solved is by changing the motherboard. It even crashes in BIOS,linux,windows and everything. It’s definitely a mobo problem IF YOU HAVE CRASHES AT IDLE. That’s all.

I’m done with this thread and forum. People here have no idea about how the issue is so much widespread but still they sight at other problems but NO ONE in this thread has been able to provide any other sources about other ideas about the “idle crash”. All I hear people say is “there maybe other possibilities” but can’t you say what other component can cause CRASHES ONLY AT IDLE AND NOT DURING STRESS TEST?? Lol this thread is so unlike level 1 techs. i’m done. removing notifications. I don’t want to be part of an incompetent,adamant and ignorant community.

0 Likes

#20

If it crashes while idling in the bios that’s not a power management issue. I think the others in this thread think when you say idle you mean entering low power states.

Bioses generally don’t use the idle states of the CPU. Idle refers to a power management state not “not doing anything” most bioses run at a conservative clock profile in case an unstable oc would corrupt your bios settings btw.

4 Likes

#21

So you can literally read wenells post, and I would wager he knows more about all of this than any of us, and you still refuse to accept you are wrong.

0 Likes

#22

In that case I will also link this thread again that I put into the PM. The rest of my thoughts I have expressed there. :slightly_smiling_face:

0 Likes

#23

Wasn’t that a problem with Haswell (?) at one point? Some power supplies couldn’t handle the low power draw and their voltage protection would trigger, causing them to reset.

EDIT: I shouldn’t say same, but a similar-ish problem.

1 Like

#24

Not iust haswell a lot of OEM systems. Out of the box premiere crashing under load is a thing. It was fixed via updates and microcode which boost the voltage slightly. It’s an ongoing problem. On the dells the temporary fix was also to disable power management but it’s a different issue than ryzen. Disabling power management is always a thing.

I would say maybe something like if after disabling all power management the sytem still intermittently locks up you should look at your Mobo ? Hah?

1 Like

#25

I’d certainly agree with that.

But to just generalize and say “X problem is ALWAYS Y” (as per @SamX above) without any actual verification/validation is how you end up with broken diagnosis (and possibly say, RMA a good board and wait for replacement when the problem is actually something entirely different - wasting both your time, the vendor’s time, etc.).

Develop a hypothesis, test, confirm result.

2 Likes

#26

I have a laptop with Raven Ridge (2200U). It locks up in Linux after a set time if I don’t turn off C6-states with zenstates.py. Windows can run longer without locking up.

3 Likes

#27

Yeah kinda i guess.
Atleast start to disable all power saving features and go from there.

1 Like