"Proxmox GPU Virtualization Tutorial with Custom Profiles thanks to vGPU_Unlock-RS" - use with P106 mining card?

Hey all, I’m following the Craft Computing guide recently posted (link removed, too new - search for video in posting title). I’m curious if my mostly-useless P106 card can be used as a Quadro so I can actually use it for something useful. Specifically I’m after 265 encoding, mostly just to use this card for a few VMs to get higher-fidelity remoting, possibly for some emulator gaming with friends. But mostly, I’m just curious if this will work.

I’ve gotten through the whole process, here’s some info:

lspci -k -s 04:00.0

04:00.0 3D controller: NVIDIA Corporation GP106 [P106-090] (rev a1)
Subsystem: ZOTAC International (MCO) Ltd. GP106 [P106-090]
Kernel driver in use: nvidia
Kernel modules: nvidiafb, nouveau, nvidia_vgpu_vfio, nvidia

mdevctl types


nvidia-46
Available instances: 23
Device API: vfio-pci
Name: GRID P40-1Q
Description: num_heads=4, frl_config=60, framebuffer=1024M, max_resolution=5120x2880, max_instance=24

cat profile_override.toml

[profile.nvidia-46]
num_displays = 1
display_width = 1920
display_height = 1080
max_pixels = 2073600
cuda_enabled = 1
frl_enabled = 60
framebuffer = 984263338
pci_id = 0x1B3011A0
pci_device_id = 0x1B30

cat 102.conf

args: -uuid 00000000-0000-0000-0000-000000000102
bios: ovmf
boot: order=scsi0;ide2;net0
cores: 4
efidisk0: fast:vm-102-disk-1,size=1M
hostpci0: 0000:04:00.0,mdev=nvidia-46
ide2: foinix-proxmox-content:iso/pop-os_20.04_amd64_nvidia_17.iso,media=cdrom
memory: 5048
name: stream1
net0: virtio=C2:67:EF:D9:CA:33,bridge=vmbr0,firewall=1
numa: 0
ostype: l26
scsi0: fast:vm-102-disk-0,size=120G,ssd=1
scsihw: virtio-scsi-pci
smbios1: uuid=c7629ed6-554c-478a-b389-c089ba05d2b7
sockets: 1
vmgenid: e2a12577-cc1a-4729-97b0-889b1dba5a59

tried to start; I get this output.

qm start 102

mdev instance ‘00000000-0000-0000-0000-000000000102’ already existed, using it.
kvm: -device vfio-pci,sysfsdev=/sys/bus/pci/devices/0000:04:00.0/00000000-0000-0000-0000-000000000102,id=hostpci0,bus=pci.0,addr=0x10: warning: vfio 00000000-0000-0000-0000-000000000102: Could not enable error recovery for the device
kvm: -device vfio-pci,sysfsdev=/sys/bus/pci/devices/0000:04:00.0/00000000-0000-0000-0000-000000000102,id=hostpci0,bus=pci.0,addr=0x10: vfio 00000000-0000-0000-0000-000000000102: failed to read device config space: Bad address
start failed: QEMU exited with code 1

any thoughts on what i screwed up here? or is what i’m trying to do actually impossible, not just silly?

chur

1 Like

I have the same error. I am using a M40 and have no idea what I did wrong or what is going on with my system

dont bother with p106 mining card they dont have encoder activated or even there one but with tesla card you can spoof that in the vm and unlock the vgpu feature with a script or passthrough the entire card to vm but that error in proxmox i have no idea i have not educate enogh myself yet so you are on your own to resolve…