Protip: 1000hz polling Gaming Keyboards may fail to get to the Tianocore UEFI boot menu

Turns out there’s a compatibility issue with Tianocore not accepting anything other than the standard polling rate for devices, and therefore fails to recognize input from gaming keyboards as a result in order to get to the boot menu. For Corsair keyboard owners, check ckb-next for newer keyboard firmware to see if it corrects the issue, or have a backup keyboard to setup Tianocore just for that purpose.

Post your results with various gaming keyboards and trying to get into the Tianocore UEFI boot menu. Success or failure? Keyboard Firmware version? This way we know which keyboard/firmware combinations to avoid so that you can properly configure Tianocore without hassle.

OVMF: pc-q35-2.11

  • Corsair STRAFE MX Silent non-RGB (FW v3.08): No go. Lower polling rate engages but no input is recognized by Tianocore.
  • Redragon Kumara K552N: Works. Gets into boot menu.

See what happens if you try to kill the ckb-next-daemon on your system before you launch the vm, that was the secret behind all of my issues with my Strafe Mk.2 RGB, because I was unable to use my keyboard unless I

A. turned my keyboard into bios mode, then started the vm.

B. Killed the daemon and started the vm.

The system/OS install I used for QEMU/KVM didn’t have that daemon installed. It’s a keyboard firmware problem if you leave it on automatic polling rate selection.

Interesting, because at least in my install, I cant even run ckb-next without that particular daemon running. I would see if my keyboard had a bios mode, I get to mine by holding F1 and windows lock for a few seconds, but I don’t know much about that particular keyboard, so I’m unsure if that is even offered. I did do some comparisons and found mine also has a 1000hz, and I’m able to launch into my VM just fine.

Okay I got to playing around with the setup, and I do also experience what you are talking about getting into Tianocore, if I don’t put the keyboard in the bios mode first, I also can not get into the Tianocore boot menu.

OVMF: pc-q35-2.11

  • STRAFE RGB MK.2 Mechanical Gaming Keyboard — CHERRY® MX Red(FW v3.24): However, if the keyboard is in bios mode, you can access Tianocore.

So a possible workaround is to boot into the VM, in bios mode, change your required settings, then turn the bios mode back off.

1 Like

Thank you for sharing that key combination, but yeah, getting that mode to stick through power cycles is what is key. I’m doing a full USB controller passthrough and the controller doesn’t power on until it gets to the Tianocore screen, so trying to set it, you have to have it preset before launching the VM and for the keyboard to remember the mode.

Here’s the BIOS mode key combo from this site:

1. Hold down the WINLOCK key
2. Wait 5 seconds
3. Now hold down the F1 key (so both keys are pressed)
4. Wait 5 seconds
5. Release WINLOCK - the Scroll Lock LED should blink
6. After a second, release F1

The page also has the documentation on how to reset the keyboard.

1 Like

Thanks for that link, honestly I couldn’t remember where I got that from, I had been doing that as a workaround to just use my keyboard in the OS for months, but couldn’t remember how I found it TBH.