Problems with my first build

So I'm using the H87M-E from Asus and two of the 4GB gskill sniper 1866 ram. I get 1 long beep and 2 short beeps nothing on screen. throw the ram in a different pc and it works. RMA the mobo with asus they send it back saying they got it to post and updated the bios. Tried the ram again same results. get on the phone with asus support tell me my 1866 is incompatible and need to get 1600. I buy some corsair vengeance and get the same result.

1866 could have just been downclocked and run at 1600.

I don't know the Asus beeps, so I can't help you out :(.

beeps mean something is wrong with ram. i'm not computer savvy yet and I can't seem to get a break just to get my first build going.

Make sure you have the ram in the correct slots. Sometimes the diagrams can be tricky.

rams are in correct slots. I've reset cmos, used different ram, tried everything I could find on the web and it's the same thing

Do you have the 8 pin CPU power connector plugged in? I forgot about it on my first build

yes everything is plugged in. triple checked it all. nothing. frustration is killing me because this has been a 2 week process trying to figure this out D:

All I can say then, is to take it all back apart and reinstall everything, following the steps of a YouTube video can eliminate anything you may have forgotten. If it still doesn't work get a friend to look it over.   Can we get a full part list?

Yeah, a full parts list would be good.

When this stuff happens, I like to take everything out of the case, unplug all of the power things, check the CPU cooler, and plug it all up outside of the case to see if it posts.

Intel i5 4750
Asus H87M-E
EVGA 600W 80B
G.SKILL Sniper Series 8GB (2x4GB) 1866
WD 500GB 7200RPM HDD
no video card
IN WIN Dragon Slayer case

I've already rebuilt it a few times same thing

Check your other thread.

Phiros said:

I had a similar issue with my RAM when I did my first build. Turns out I didn't put enough pressure on the sticks when installing them as I was flexing the board and worried I might damage it. A bit more force and I got them working.

TL:DR try taking the sticks out and putting back in with a bit more force than you'd expect to need.


You really need to take Some Tech Noobs advice. Take the motherboard with cpu cooler plus fan and ram and power supply OUT OF THE CASE. Plug the motherboard 24pin and 8pin power cables up. Leave the cpu fan plugged into the motherboard. Leave ram in motherboard. Plug your monitor into the motherboard. I prefer VGA or DVI to monitor for testing but if HDMI is all you have then do that. Check all connections plus ram. Plug power into power supply.Turn on power supply. Turn on monitor. Short (touch) the 2 power button contacts (pins) on the motherboard (where you would plug the font panel power button into) with a small screw driver.

Did it post? Do you see the bios?

If not remove 1 ram stick and try again.

That 1866 ram you have is not supported but should down clock to post as Some Tech Noob pointed out.

edit- put the motherboard on top of the cardboard box  it came in or on top of a non-conductive surface.