Problems with FreeNAS and LEMP stack configuration

I've searched high and low ( maybe because I'm an idiot ) and I can't figure this out .

I installed LEMP in a dedicated LEMP docker host, I created a fresh dataset and share.
A user was created called 'www' (I've also tried other usernames and configs 'webdev' 'wwwuser' and so on)

I tested the .PHP script which is included in the readme file and it worked like a charm! I dropped the index.php in the share and everything worked in the browser.

Now here's the problem - I wrote a simple index.html to test the html in the webserver and I keep getting 403 Forbidden. As far as I can see I cannot do anymore with the permissions for the user 'www' . And when I check permissions in the Serial Console I get this :

namei -l /var/www/html

f: /var/www/html
drwxr-xr-x root root /
drwxr-xr-x root root var
drwxr-xr-x root root www
drwxrwxr-x 1002 root html

This seems okay since the user ID 1002 is the user 'www'

The webserver can execute .php but not .html as it seems.

Help? :)