Return to Level1Techs.com

Problems with Corsair Void Pro Mic

#1

I have an issue, and I thought I would get it worked out soon, but, alas, no.
I recently got a new ssd when the Samsung 960 Evo 1Tb went down in price. I botched my install by erasing everything off my main drive, so I went ahead and just started from scratch, with the new drive as the main “C” drive.
I grabbed my motherboard drivers, graphics drivers, and went through the whole setup with W10 Home. I have some Corsair peripherals, the Void RGB USB headset, keyboard, and mouse. All of them light up with the iCue software. But after installing iCue, everything went wonky and froze my entire pc up. I uninstalled it, deleted remaining files, and re-installed it, and it worked.
I have a USB 3.0 extension cable running to a 3 port usb hub so I can game from the couch. All 3 peripherals used to run on it fine. But My microphone sounds like it’s broadcasting from a far-away galaxy. It cuts in and out and sounds like Darth Vader on meth.
I have spent over 20 hours in the last 3 weeks playing with the settings, uninstalling and re-installing things, and tried to change a registry file of some kind I saw online. No luck.
I have a second usb 3.0 extension, so I tried plugging just the headset into a USB 3.0 on the IO panel. My computer fails to recognize it. When I check it in the control panel under device manager, it will not let it connect at all. I tried uninstalling it and rebooting to get new drivers, but no luck. Right now I have it running in pass-through off my keyboard for audio, and iCue recognizes it there.
I thought my USB ports were fubared, but I plugged my mouse in and it works perfectly.
There has to be some kind of secret ninja shit that can be tried. I also have a wireless Xbox One controller and wifi dongle hooked up. I had some issues with that after upgrading the drive, but I managed to fix them.
Any ideas out there? I would be interested in figuring this out so I can chat in-game while I’m being t-bagged by 10 year olds.

1 Like

#2

Some more PC specs (mainboard) would help.

Sounds more like a case for Support and RMA than anything else.

0 Likes

#3

Motherboard- https://asrock.com/mb/Intel/Z97M%20Pro4/
It’s about 3 years old now. I have had the headset, keyboard, and mouse connected for about a year with no issues. I handle everything pretty carefully.
I’m sure if I contacted Corsair and told them everything worked perfect until the last Windows install and update, they would blame it on W10. And MS would say it is a Corsair issue.
I did try using the headset without iCue, also, just to see. It was the same.
I think it might be Window’s automatic driver setup not working out. I tried looking for a driver for the headset, but no luck. The only driver for it comes through the iCue application itself.

1 Like

#4

So, I finally found the fix for my headphones, and I thought in the interest of helping, I would post the solution.
After trying to use my known good usb 3.0 extension cable for the headset on every usb 2.0 and 3.0 header on the entire pc, i just plugged the headset’s usb in directly to a front panel usb 2.0. And it worked. LOL. But it was intermittent.
Using my brilliant powers of reason and deduction, I ordered a usb 2.0 extension cable, then plugged that cable into the front usb port, and plugged my headset into that. I called Corsair because the mic was working but kept cutting out at random. They had me change the sound settings under the headset properties.
Now my headset mic works flawlessly. Once again, this was all caused by a W10 update after upgrading my ssd and installing a fresh copy of W10.
I can’t believe I had even taken the whole thing apart and resoldered the mic leads in case of a cold solder joint. I happened to have good tools for that job on my workbench and it only takes 5 minutes. But this level of insanity should not be required for regular users who are having their stuff bricked every time there is a new update.
When I go to turn off my pc and it says “Update and Restart”, I get the worst case of cold chills and anxiety. Not cool, MS, not cool.

1 Like