Problems installing Linux on an old laptop

I have run in to some problems when I've been trying to install Xubuntu on an old laptop, specifically a Dell Latitude E4300, from 2008 (I think... don't quote me on that).

I torrented the ISO and created a bootable USB-drive, all fine and dandy thus far. I opened up the BIOS and changed the boot order. But when I started it up, the only thing that appeared was a black screen with a blinking cursor. When I try the same USB on my normal desktop computer, it works like a charm.

So I was thinking that the computer might be to old to boot from USB and that I might need a Live CD/DVD instead. Could this be the case? I thought it would be best to ask you guys/gals before I buy CDs/DVDs to burn to.

On a side note, I was thinking that it might be a good idea to try Trisquel (Mini). I really would like to cut out as much proprietary and closed source software as possible from my life. Has anyone tried it? What did you think?


if your computer's BIOS sees the USB in bios as a disk there shouldn't be any problem. That is because unless I am greatly mistaken that if done correctly your usb drive will have MBR.
I normally use Unetbootin to make my USB bootable drives I recommend using that if you haven't already.
If you are having issue try a different mirror and do a checksum on your D/L

Hey go Trisquel is you love opensource otherwise try anything else.

Are they both 64-bit machines? Did you wait a substantial amount of time before shutting down the Latitude? I just installed Xubuntu on an old work computer and it took a bit before it showed the login manager. I was worried because I wasn't getting any kind of output, just a blank screen (no cursor, however) but after about 30 sec to a min, it was fine.

Also, I've run in to some problems with an old Macbook and had to throw "nomodeset" in the kernel options in GRUB. Maybe give that a try?

You may be running into an issue with kernel modesetting. I've had this issue when installing certain distros on servers.

If you're able to get to the usb drive's boot loader, can you try editing the settings on the kernel command line, adding nomodeset to the end?

Usually if it's an architecture mismatch, you'll run into a very quick kernel panic or it will tell you that there's an issue and cannot continue.

EDIT: looking at the specs for this model, it has an Intel GMA 4500MHD, an Intel Core 2 Duo SP9400 and would come with 1 to 4GB of ram, so it's definitely well within the acceptable range for running Linux. I'm not too familiar with this era of the Intel GMA chips, but I have a feeling that's the culprit.


If you get the "Verifying DMI Pool" message after the Bios screen it's possible you may need to do some tinkering. Older systems have an issue with booting Live Media from USB even if you set the boot order in the BIOS or F8 into the right drive.

Since BIOS may vary you might have to google, your Laptop model and BIOS info with "Boot from USB"

Thanks for all your comments. I thought I would give you an update on my progress.

I explored quite a lot of avenues when trying to get the USB to work. I formatted the USB drive using both MBR and GUID, not that it should make a difference really, since GUID is backwards-compatible with MBR. Unetbootin is also my Bootable-USB-Utility of choice. And I always checked MD5 sums.

I tried both 32- and 64-bit versions of the operating systems. I tested Trisquel, Kubuntu and Ubuntu. I waited, sometime, upwards of 20 minutes for it to boot. I wasn't able to make any kind of input, it went straight from BIOS splash screen to black screen with cursor. I thought that I might as well install an update for the BIOS so I clicked on download but all Dell gave me was a HTML 500 Internal Server Error.

I sort of gave up on booting from the USB so I went out and bought a DVD, burnt a Trisquel Mini ISO to the disc and it booted up, GRUB screen and everything, without a hitch. I not quite sure if I'll stick with the OS. I really like it, but it doesn't seem to exist any free and open source drivers for my wireless card. I could buy a free software compatible wireless card or wifi dongle for about $40-$50+shipping. I guess it depends on how much I value my freedom.

1 Like