Problem with booting GB x370 gaming 5

Here are the specs of my pc:
-Ryzen 1600 no overclock
-GB x370 gaming 5
-8gb ram stick from goodram
-GB Windforce hd 7870

I have openSUSE Tumbleweed and windows 10 ltsb dualboot set up, where grub is managing what to boot with suse being default.

Here is the problem:

  • boot pc
  • everything goes fine, POST etc.
  • get to grub and menu with choices what to boot into
  • try to boot into suse:
    • monitor goes black
    • after 2-5 secs all IO stops working (indicators on keyboard turn off, mouse lasor turns off)
  • try to boot into windows:
    • monitor either goes black or for around 10 secs green and black vertical lines are shown, after which it goes black
    • all IO is shut off after 2-10 secs

I can access the bios without problem and i can be in bios for whatever amount of time i want

I am running f9a bios version.

Welp please. ._.

Can you bypass grub boot from the UEFI to try to boot Windows directly? Are the symptoms the same? If so, you may need to switch to the last good non-beta BIOS. I know Gigabyte BIOS naming nomenclature has F# as production BIOSes and F#(a-z) as beta BIOSes.

I tried to bypass grub on f9a and still had the same problem.
I rolled back to f8 and tried to boot into suse and windows using grub and still same problem
I tried to bypass grub from uefi and still same problem.

Is it a memory issue? Try the default speeds or even try running memtest86+.

I am running memtest right now so far so good, but i noticed that 8gb mem stick should be 8192M right? But memtest shows as 8141M?

edit: i never messed with memory speeds so it always stayed on default 2400MHz

That’s normal. What’s not normal is how it’s not going past POST with higher demand from the low level functions of the GPU. Almost seems like a GPU incompatibility. Can you test with another GPU? If you don’t have a spare, I recommend you try to get a cheap GPU temporarily like a GT 1030 to see if it was the GPU.

I’ll let the memtest finnish and after that i’ll borrow gtx 660 (i think) from my gf.

I just remembered that before pc started to act up, I started to experience some artefacts on screen.
Nothing major though, and after 15 secs after getting into one of the OSes it was gone each time.

Yup. That’s GPU memory or the core going bad. It’s the GPU if your RAM is fine.

Does it mean i have to buy new GPU? ._.

edit: I guess it’s kinda rethoretical, but you know, denial->rage->trying to find solution…

Unfortunately, yes. If your 660 from the other system is fine, your GPU is toast.

1 Like

Ok, it works with the other card. Thank you very much for help. Fuck me though, i have to buy a GPU in these cryptominers times. Oh well, again thank you very much!