Return to Level1Techs.com

Problem: Plugging in headphones changes volume on a different scale

This is a bizarre issue, I wasn’t even sure how to describe it for the thread title. I’ll do my best to explain it,

Situation 1:
Most of the time I use external speakers, so my system volume is at 100% and I control volume with the knob on the desk speaker.
When I plug In my headphones to game with friends or jump on discord, the system volume reverts to the last volume I had with headphones, usually around 8-16.
A volume of 20 or higher will absolutely damage your hearing, I have accidentally bumped it to 18 once and I had instant regret.
I unplug and it goes back to 100% through speakers

Situation 2:
After some amount of time or an event that I have not been able to precisely determine, I go to plug in my headphones…
Volume jumps down to somewhere in the 60-70 range.
Low sound coming from headphones, I could crank it to 100 without being overbearing.
Unplug and system goes back to 100%

A restart will 100% fix this, by fix I mean after restart, I plug in headphones > volume jumps to 8-16 range and is way loud, like normal. This happens weather I leave them plugged in during the restart or not.

I’m not sure what is happening, it’s like my PC is remembering 2 different volume scales. Whenever it reverts to the “high number = soft” it will remember the previous level, just like in “high number = deafening” which to me is normal mode. I usually leave it at 64 in the soft scale just to be sure so I don’t accidentally deafen myself. Every time I plug in the headphones after the computer has been on for a little, its at 64. Restart > 12.

Things/guesses I have tried to do to duplicate this issue that have not worked:
hibernate wakeup
sleep wakeup
open firefox
watch a youtube video
watch a twitch stream
open windows media player and play music
open steam
open discord
open discord then steam & vice versa.

I don’t know when or why this is happening, and I have never managed to catch it as it is only revealed when I plug in headphones. It is driving me crazy because I have to restart EVERY time I want to game or talk on discord. The only guess I have is a driver issue? I checked windows update logs and this issue MAY have started soon after a driver update, but I would need my hand held in walking that back or reverting. I’m using the front panel I/O, and will see if going through the back the next time makes a difference. I’m also using the same pair of headphones, every time, they are my only pair that I’ve had since I built the PC, this is a new-ish issue. I have posted on other forums and redit but nobody has replied on redit, and I got one response on tomshardware that wasn’t helpful.

Please give me a hand, I would much appreciate it!

Are you connecting your headphones to a 4-pole connector?
Windows is using a per-device volume rather than a global volume so any audio device retains the last volume it was set to when disconnected.

1 Like

I would not trust software when it comes to my hearing.

You could just get something like the Nobsound Little Bear MC102 And use that to switch between speakers and headphones.

1 Like

No, there are 2 separate mic and headphone cords in the bundle, each is a 2 pole.

That per device idea would explain part of it, but I’m using the same device, and when it changes the level of the 64 on one scale is a drastically different 64 on the normal scale. the problem scale 60 is barely audible, where 60 when things are normal would be 110 Db plus, I wouldn’t put them on my head. When I open the volume mixer everything seems identical between the 2 scales.

So now another question: do you have any software on your motherboard that auto detects impedence of the devices you connect?

Not to my knowledge, I just installed my motherboard drivers when I built the system a bit over a year ago and haven’t installed anything else. I checked for updates and have installed whatever is available. Here’s a link to the mobo

I have a Maximus VII Hero and when I connect headphones to the front panel it detects the range of impedence and sets the correct one. Yours should do the same (to check open the audio panel from system tray and look on the right side of the window).
What I think it’s happening is that your motherboard gets somehow tricked into detecting different impedences for whatever reason when you connect your headphones. This causes an incorrect setting of the power used to drive them. That’s why you’ve been detecting different volumes while connecting the same headphone while keeping the same volume.

Set a hard limit to 16%. I assume you’re in windows? From what I recollect I had this same issue eons ago in windows XP and I just went to driver properties and set a hard limit.

The trouble with setting a hard limit is that 16% on one scale is much different on another.

I think you’re on to something with that auto detect impedance. I’m in windows 10, I’m not sure where to go to find the detected impedance level.

when I click on the audio tray icon it just gives me a simple volume slider, when I right click I get, Open sound setting, open volume mixer, Spatial sound (off), and troubleshoot sound problems as my choices. Open sound settings seems to be the only choice that leads anywhere, not sure what else to do from there though.

I was thinking that maybe the cord was getting old and a frayed wire inside may be giving it different values but I’ve tried messing with it every which way just now and it’s currently stuck in the quiet mode. I was hoping that maybe holding it a certain way and checking all the in line connections would make it drop back to 16 but it’s still in quiet mode. the rear audio just thinks it’s a speaker and stays at 100 when plugged in.

I also disconnected the actual headset and mic from the cord as it has a 3 pole extension midway though, so I was essentially plugging in just an extension cord and that didn’t change it either. I also had a random aux cord I used in my car and plugged that in with the same effect. Volume goes to 60 - quiet mode.

Well I think I made things worse, I went to the asus website and re-downloaded the realtek audio driver Version 6.0.1.8746, now when I plug in the headphones that ROG SupremeFX software pops up and asks what I just plugged in, when I select headphones, it starts blasting at 100, I set it to 12 and it’s in the loud mode, which is good albeit annoying to have to click on a prompt when before I could just plug in my headphones and have them work. But now when I unplug them, the master volume doesn’t return to 100% for my desk speakers…

EDIT uninstalled this update, seems like a BS software suite, but it did show the impedance level detection when I plugged in the headphones.

Then when i restarted the headphone volume was in the 60s and loud, maybe this fixed it? We’ll see. God help me if I have to resort to the geek squad to fix this.

So you weren’t using the SupremeFX driver before, so that couldn’t be issue.
If that’s not the issue this issue truly leaves me clueless. It might just be the Windows generic Realtek driver that’s giving you some headaches.
Also I think you can just set the impedence in the SupremeFX driver and never have the driver ask you every time. I don’t remember right now if you can do this or not because I’m not home and I’m using a Scarlett to power my headphones.
I’ll get back to you if you want.

1 Like

I appreciate the help, I’m going to continue fiddling on my own. I’ll report back. Thanks a lot, I have received more help from you here than I have in the past 3 months on this issue.

This may help, this may not help.

  1. Go to your Sound settings and the Communications tab, set it to “Do nothing”
  2. Go to the Playback tab, disable all devices you never use
  3. Open the properties of each device you do use
    a. On the Enhancements tab of the properties check “Disable all enhancements”
    b. On the Advanced tab uncheck “Allow applications to take exclusive control of this device”

On the Playback tab I’d also note what device it says is playing when the headphone audio is working properly and when it is borked just to make sure nothing is different.

It does seem like your computer is remembering your headphones as two devices.

1 Like

I will try that also, thanks for the reply

Tried all of these, nothing worked, and I still have not been able to duplicate it at will. Every so often throughout the day I’ll just plug in my headphones to check, sometimes it’s normal, sometimes it’s in quiet mode. and once it’s in quiet mode It can’t be fixed until I restart, since the last post I’ve been using different headsets and cords while troubleshooting with no change in results. Restarting still always fixes it, weather leaving them plugged in or unplugged…

Maybe I’ll leave them plugged in at all times and just switch the output from speakers to headphones with the control panel. This would avoid the physical plugging and unplugging action that maybe causes the shift in amplification. Don’t want to spend money on a desktop apparatus that does this until/unless I fully understand the problem.

I don’t know if a reformat-reinstall windows would even fix it so I may have to accept that from now on I need to restart my computer every time I want to play games or use discord, at least it’s fairly quick. Since the problem can’t be reliably duplicated I can’t bring the pc to geek-squad or a tech support center for help, so I’ll just have to mark this problem as unsolvable.

Feeling defeated but at least it’s a first-world problem. Thanks for the help anyway, I do appreciate the efforts.

I normally use ‘loudness equalization’ in the settings which has the net effect of making the sound initially jump and then it evens-out content volume pretty well. Whenever windows does an update or decides that device needs a driver update it mucks with that setting (silently, of course).

Not your specific issue, but I thought I’d toss it in the thread for future information. You’ve probably already looked at this setting.

However, I used to run my volume (to an external amp) at a nominal 12 and it now needs 20 after an update and I had restored that ‘loudness equalization’ setting. Windows appears to be doing something wrong/weird with the audio because nothing else changed besides a windows update and it was very obvious when it changed.