Problem Installing Linux

So, I just built my new pc (Asus Maximus VI Extreme mobo) and installed Windows 8.1 on an SSD. I then wanted to install a linux distro on a new and clean HDD. I chose Ubuntu for the time being, as I want to learn to work with Linux and grow more proficient.

At the time of Windows 8.1 installation my HDD was not plugged in. Then I went onto another computer, downloaded Linux 12.04 (64 bit) LTS. Used unetbootin and installed it on a flash drive. Unplugged my SSD, plugged in my (I repeat, clean and new) HDD. all ready to install Linux. Changed bootorder in bios to flashdrive.

It didn't work. And what I meant by that is that I get this screen. So, I thought. Ok, no problem. *hits install* but nothing happened after that but a black screen staring back at me. So I tried messing in the bios to see what I could change to get it to work. No luck.

So then I hit up my old trusty pall, the internet. And I've narrowed down the problem. It seems the UEFI is blocking ubuntu to install. So then I thought, fine I'll switch to legacy mode and all will be well. Again, no luck. As a matter of fact, as soon as I switch to legacy mode, it doesn't even recognize my usb-stick. So there is no way to even access the usb stick in legacy mode. And when I take a closer look, I can see my usb-stick is in UEFI mode. So now i'm wondering as I want to install Ubuntu on that empty HDD, what do I need to do? And I think switching to other distro's won't do any good and I'll just run into the same problem, and even if switching distro's would do the trick, I still want to know an answer to this question. So, my internet wizard friends, share your knowledge with me.

Humbly yours,

- GrimWaltz

I've had close to the same problem installing kali linux onto one of my PC's and for me it ended up being that the ISO i used to create the bootable USB stick installer was corrupt. If you made the bootable USB from an ISO, maybe try re-downloading it and creating the stick over again. It was the solution to my problem.

I also recommend this free program:

It seems to work well in creating bootable Linux flash drives for most distros.

Try disabling secure boot if it is on in your BIOS.

I have had issues with my Maximus V Formula before. After I flashed the BIOS, however, the UEFI issues I was having went away. Are you on the latest BIOS?

First of all, don't use Ubuntu 12.04. It's outdated, actually, pretty unstable, and not the main target for developers. For a beginner, I would recommend something along the lines of Manjaro or Sabayon, which are based off of the venerable Arch and Gentoo distros respectively. I'm not trying to push Arch or Gentoo on you, it's just a simple fact that the software available, performance that comes from that bleeding edge software, and features that come as well, are more apparent, and in higher quality and quantity access on Arch/Gentoo and their derivatives. Both Manjaro and Sabayon offer their own benefits as well, including very easy to use graphical installers (both forks of Anaconda, I believe - Sabayon is definitely), and choices of multiple desktop environments. They will perform better, support more hardware, and offer a better experience than any LTS version of Ubuntu available right now. It would help to know how you burned the iso, as well. I recommend using Win32DiskImager, if you're on Windows, to burn whatever iso you end up using. Never had issues with it - there's also "dd" via Cygwin, but you may as well just use DiskImager.

I tried that, but it really didn't change much, unfortunately. I'm sorry, I should have noted that in the post.

I'm not on the latest bios, I didn't think that would change much, but I'll give it a shot. 

I'll look into Manjaro and Sabayon, thx :) 

I didn't burn the ISO's. I used unetbootin so I could install it off a flashdrive. I hardly use DVD's nowadays, only for long time storage or backups I really really need if something were to happen to my pc. 


I'll try that out, thx. :) 

You misunderstood; use Win32DiskImager to burn the iso to your USB drive, not a DVD. It supports both optical media and removable media.

Ubuntu 12.04 is too old to be UEFI enabled. You have to install at least 13.04 or 13.10 to get UEFI support. The trade-off is that it's a development release, not a LTS release, so you'll have some breakage and problem solving to do. What you can probably do, is install 13.10, then downgrade to 12.04.4 LTS for a stable version without too much spyware.

If you really want Unity, but don't want to deal with the UEFI mess and have a stable system, an alternative would be to install Manjaro or Arch, and install Unity from the AUR.