Problem detecting NAS on home network

Hey guys, new to the forum, any help is welcome.

Having trouble with certain computers on my home networking from being able to map the network drives on a western digital mycloud nas. Some computers on the netwrok find it fine whilst others i have to use the wd software to access it over the internet rather than thru the local network.

All computers connected to the network are running windows 10, and the nas is directly connected to the router via gigabit ethernet, and then accessed via 5 ghz ac wifi.

any help or tips are welcome

Check the router's admin panel to see what the IP address of the NAS is. then try mapping your shares as network drives, using the IP address rather than the device name.

Of course you'll need to find out how to make sure it always gets that IP address, otherwise your PCs may fail to find it again after you reboot the NAS or the router.

1 Like

How many computers are having the problem, can you isolate their network controllers, share a tiny review of the WDNAS with the community in your post x

Honestly connecting the nas to a PC isn't a terrible idea then use a domain from the PC to have full control over any computer assigned to the VPS; mainly for comfort.

Might be wrong here: control panel-network&internet-network&sharing center-advanced sharing settings(HomeGroup); make sure network discovery is on (auto) and check the all networks tab because profiles and media streaming options on all devices involved. Update windows on all the devices, new here too.

I've Had the same issue with w10 and shares on the work network. I have to refresh many times and sometimes it just doesnt show up. The quick fix for me is always referring to the IP directly with: \\ (where xxx is the octets of the IP the NAS has)

You can pop that into your run terminal with windows key + R. For instance mine is \\, yours will be different. You will have to refer to your routers DHCP pool to find the IP in all likelyhood.

1 Like

automatic network discovery is on all pcs, and all have latest updates, its strange 3 pcs can access wd mycloud shares as drives fine, and three cant, will try mapping with the ip address during half time of liverpool vs chelsea and be back in a bit, and many thanks for help

hey guys, so update is managed to map one of the network shares by mapping via ip, and logging is in to the mycloud, will update after match how it went with the rest of the pcs and mapping other shares

regards and thanks again

p.s. anyone think its wierd that the wd software for mapping shares on the network couldnt find the mycloud on the network on any pc, yet they mapped fine, and were found by the monitoring software no problem?

worked right away that method for finding all the shares, and then selected map network drive by right clicking on desired share

thankyou very much, 1 pc down, 2nd half and 2 other pcs to go

You can run the command:

arp -a

You should see the MAC address of the device associated with the IP address it is assigned.

What is typically the cuplrit is when a DCHP assigned device stays running but the DHCP server has been reset, which loses it's database of assigned MACs to IP. So if you had to reboot your router, you'd lose your DCHP table.
Easy solution is to set static IPs as much as possible.

hey guys. so far so good on other pcs mapping the network drives, thankyou very much for all the help, it has been bugging me for a while, mycloud is a decent simple nas to use, just a bit of a bugger to map, but ive also learnt a few thing i didnt know so all good


1 Like

so was solved with using windows key and r, using the nas ip address and just mapping the netwirk shares there

thanks for the help everyone, much appreciated