Private Internet Access on Ubuntu 16.04

So I used wget to download the zip, unzipped it, and I basically get a list of files.

AU Melbourne.ovpn Israel.ovpn Turkey.ovpn
AU Sydney.ovpn Italy.ovpn UK London.ovpn
Brazil.ovpn Japan.ovpn UK Southampton.ovpn
ca.crt Mexico.ovpn update-resolv-conf
CA North York.ovpn Netherlands.ovpn US California.ovpn
CA Toronto.ovpn New Zealand.ovpn US East.ovpn
crl.pem Norway.ovpn US Florida.ovpn
Denmark.ovpn US Midwest.ovpn
France.ovpn Romania.ovpn US New York City.ovpn
Germany.ovpn Russia.ovpn US Seattle.ovpn
Hong Kong.ovpn Singapore.ovpn US Silicon Valley.ovpn
India.ovpn Sweden.ovpn US Texas.ovpn
Ireland.ovpn Switzerland.ovpn US West.ovpn

I then connect using sudo openvpn "US Midwest.ovpn"

However, it seems very limiting, unlike when I run PIA on windows. For example sudo apt-get cannot communicate with the ubuntu servers. I still am able to browse the web, but occasionally get hiccups.

Could this be something with the iptables? Is it just the way it is with vpn's on linux? Have any ideas on what to do?

Edit: So I am able to communicate with the ubuntu server. It just seems that I keep getting hiccups though, where my vpn session will drop. It happens like every hour or so.

Can you post the contents of the .ovpn file you're using? Also have a look in the log (pretty sure openvpn uses syslog which is at /var/log/syslog) see if you're getting any errors which are causing your connection to drop.

GNU nano 2.5.2 File: VPNPROBLEM.txt

Thu Feb 18 23:22:41 2016 Initialization Sequence Completed
Thu Feb 18 23:24:40 2016 [Private Internet Access] Inactivity timeout (--ping-r$
Thu Feb 18 23:24:40 2016 SIGUSR1[soft,ping-restart] received, process restarting
Thu Feb 18 23:24:42 2016 UDPv4 link local: [undef]
Thu Feb 18 23:24:42 2016 UDPv4 link remote: [AF_INET]

Thu Feb 18 23:25:43 2016 TLS Error: TLS key negotiation failed to occur within $
Thu Feb 18 23:25:43 2016 TLS Error: TLS handshake failed
Thu Feb 18 23:25:43 2016 SIGUSR1[soft,tls-error] received, process restarting
Thu Feb 18 23:25:45 2016 UDPv4 link local: [undef]
Thu Feb 18 23:25:45 2016 UDPv4 link remote: [AF_INET]

After installing proxychains and rebooting several times I actually now am able to connect to the vpn through the ui in the top right control panel. So this may no longer be an issue. I also restarted my router. I will let you know if this problem still persists, because if I still keep getting session drops, then it's still probably the same issue as above.

Also since PIA is using UDP, I have to use SOCKS5 if I want to do proxychaining, right? this udemy course I'm on says SOCKS4 disallows udp and ipv6.

looking at the syslog, it appears to be fixed, because the timestamps from about 10 minutes ago were giving off a ton of network issues. Now it doesn't seem to be an issue.

But hey, I learned something. I wasn't aware about syslog. (I'm new to linux). So thank you. I guess this isn't an issue any more... as far as I can tell.

So right now I'm using a VPN and TOR. Would there be any benefit to actually buying this?

It's $60 a month and I can set up proxychaining. Is there really a use for this? The course creator seems to think there is...

I wouldn't mind paying for a month, just to try it out, or say that I've done it. What do you guys think? Is this a dumb thing to pay for?

VPN + TOR + PROXYCHAINING = $70 / month

edit: I don't really have anything to hide. I'm not hacking anybody. I just want to follow the course in specifics. But hypothetically, if I were hacking... would I benefit from this? Here''s the course. Just to be clear, I'm working to become a pentester.

So this guy says no. But other people say yes.

I don't think it's worth spending $60 on. It doesn't really protect you from anything if you're not doing anything illegal and doesn't offer anything benefit over using a VPN or tor. Personally I would use one or the other, not both. But it depends what you're trying to protect yourself from.

If you're using it through the VPN then it doesn't matter. Any kind of traffic can travel within the VPN tunnel. If you were trying to use the VPN over the proxy (not sure why you would want to do this) then yeah, if it doesn't support UDP then it wouldn't work unless you used TCP for the VPN.

1 Like

I will make soon a tutorial on a the forum how to set up OpenVpn ou ovpn fils in Ubuntu stay tune..

Did not read the thread, these are my notes on setting up PIR in BunsenLabs (Debian derivative inspired by Crunchbang):

sudo apt-get install openvpn
sudo apt-get install network-manager-openvpn network-manager-openvpn-gnome #if network-manager is being used, for BL
sudo systemctl enable openvpn
sudo systemctl start openvpn
cd /tmp
sudo wget
cp ca.crt /etc/openvpn
cp crl.pem /etc/openvpn
#In network-manager, create "OpenVPN" connection, follow
#In regular connection general properties check "automatically connect using... VPN"

I didn't have to muck with anything else. The ubuntu install script PIR provides nuked my DE so I had to restore from a backup. Make sure you're using network-manager if that's what your distro ships with. Running "dkpg --get-selections | grep network" should list network-manager and the relevant goodies. After moving the certs to /etc/openvpn for convenience, you should be good to configure the VPN in the gui.

EDIT: Also didn't read the date, oops

I know this is an old thread, but I just installed Ubuntu 16.04 on an old laptop I thought was dead. I was trying to get PIA setup and kewiha's little walkthrough worked. I did have to 'gksudo nautilus' to extract the ca.crt and crl.pem files to /etc/openvpn