Possible corrupted bios?

so i had a fan not working which i removed. it didnt work in the 10+ year old pc i had it in so i tested it in my main rig. after removing it and rebooting i found i could not boot into bios or at all. it would get to the "press delete" part and freeze. i unplugged and plugged in several fans and ended up moving one fan while in the bios then rebooted while still in bios. 3 times i was able to get into bios after pressing cmos only to freeze up at the select boot drive part. a 4th time i was able to boot all the way to windows by clearing cmos then waiting until it got to the "first time set up press f1" thing. now it wont boot even if i clear cmos. i have reset all the parts but cpu just in case. what else could it be? i run virus scans all the time with malwarebytes and i ran the most advanced scan after adobe updated 2 days ago.


It might be, but looks really really weird. If you have the option of being able to flash the motherboard with those options like EZ flash (or something like that that's on the Asus boards and works even without a CPU) you might aswell try. Even better would be if you have the removable BIOS chip on the motherboard. There are a lot of ROM readers that works through USB and you can try to write back the BIOS the way it was.

soldered on bios chip and you need to get into the bios to update it and not dual bios.

Any addon cards installed that you could try without?

no cards other then my gpu and no igpu.

i doubt its a corrupted bios.

I would try to clear the cmos first

1 Like

Clearing CMOS would be the first thing I would do

1 Like

i have done so many times read op.

I corrupted a BIOS on an old motherboard, and actually bought a replacement BIOS chip on eBay. However, since your's is soldered on, you're hosed.

10yo is a little old for 'usb flash bios'.... but....

Some motherboards had a special jumper combination where they would read from the FLOPPY DRIVE the BIOS file.
It has to be a real floppy drive - attached by the 34 pin cable - none of that USB floppy drive bullshit.

Maybe if you told us the model of the motherboard, we could help you more.

See articles like this one. You'll have to rename the bios file to a certain filename and do the rain dance.

asus z97 m plus and checking the receipt im actually covered by micro center for a replacement.

1 Like