Port Forwarding Router+Modem

Hello Everyone,

I am trying to set up my cable company's modem (Arris TG862 with Arris not Xfinity firmware) to be nice to my router (Linksys WRT310N). I have minimal experience.

I have recently switched ISPs and until now haven't needed to port forward for anything. I'm using WOW. The problem was unearthed when I tried to host a game of Risk of Rain. With my previous ISP, I had only needed to forward on my Linksys router, so I tried that, but it didn't work. I have also tried my previously forwarded safety of Warcraft III, but that didn't work either. I've used canyouseeme.org and it usually says, "connection timed out," or sometimes, "connection refused." 

I've also tried to port forward on the Arris. I set up "Fixed DHCP Clients" for both my computer and the router, changing the IP on both to 192.168.0.xx to match the modem. I can't connect to the modem through the router when their IPs are in the same locale (x.x.0.x). So, when I directly connect to the modem with my computer, I then go into virtual servers and forward ports 11100 in both UDP and TCP, using the computer's static IP. But it still doesn't show the ports as open.

I've tried using Simple Port Forwarding, which shows the ports as being open, but canyouseeme.org doesn't show them as such and neither does Risk of Rain and perhaps WCIII (or nobody tried to join my hosted game). 

Thanks for your help.

I dont know anything about that hardware, but have you looked to see if you can set the Arris modem into bridge mode? This will have it function as a modem only and your router will take over all routing.

Thanks for the reply,

Would that be under LAN > NAT mode? Does that sound like the right place to apply bridged mode?

Ideally you should put your modem in bridge mode (alternatively you can disable DHCP on your router and just connect the modem to one of the LAN ports, this way the modem will be the router)

If you can't get that to work one problem I saw in your set up is having your modem and router on the same subnet. If you have one router connected to the other on the WAN port then they need to be on separate subnets, this is why you can't forward the port from the modem to the router. So when they're on different subnets you would want to forward the port from the modem to the router's WAN address (not it's LAN address) and then forward that same port from the router to the computer's address.

So, if you have the modem connected to the router on the WAN port (and it's not in bridge mode and therefore is also a router) then you need to use different subnets, but if you disable DHCP on the router and connect the modem to one of the LAN ports then they need to be on the same subnet.

Thank you very much, 

I'll try to do that tomorrow, starting with bridge mode, and update the thread.

I have it set to bridge mode, but now I think I'm having trouble with the Linksys router. The forwarding isn't working. I'd prefer to maintain bridge mode.

Any suggestions?

Quick thought - your router is fairly old. Linksys (before Cisco and now Belkin) firmware has always sucked. 

DD-WRT is supported on both revisions 1 and 2 of your router. You should start with that. It'll probably resolve your issue.

So in bridge mode you have your modem connected to the router's wan port and you have the WAN interface configured correctly? If that's the case then I'm not sure why port forwarding isn't working do you.

Your statement about statically setting DNS clients was very confusing (unless you're strictly using your "hosts" file for IP lookups or something really strange). Maybe this will help...


Otherwise, I'd suggest looking into firewalls and A/V clients since it sounds to me like one of them is screwing you up more than anything else.

... And once you connect your modem to your router, you might like to try addressing the modem's admin menu at (that's different than your Linksys router admin menu which is usually