PopOS Static tearing/line everywhere

Hello to everyone!
Pretty new at the Linux side of things so I might say some nonsense down the line.
I know that Pop OS it’s based on Ubuntu which has roots in Debian so I figured that it will have pretty good support from the community and a decent amount of good programs. I was right in this regard with 1-3 exceptions, but doesn’t matter that much.
After years of playing on a custom resolution, 1440x1080, I would not accept anything else when it comes to home gaming.
But the problem is that a line showed up and it’s tearing my image everywhere(games, programs, etc.) and makes it desynchronized.
Here are some screens:

I have tried:

  • to make a new xorg.conf.d file with some lines that should have enabled TearingFree
  • a new install
  • updating anything I could

But I had zero success.
This happens just at 1440x1080 and because of that I presume that it’s a driver issue.
With my half a cup of knowledge, I think removing amdgpu driver and installing an older version could make a solution for my problem.
What is your opinion on the matter? What could have gone wrong? :confused:

Do you happen to have a 4K 30 inch+ panel?

It’s a 24" 1080p panel. It’s not something high-end, more like a budget panel.

Hmmm. I was gunna say I’ve seen this sorta behaviour on multi-link panels where its multiple panels put together.

I would have thought so too if I had a 4k panel. Unfortunately it not that easy for me to solve this.

Is the tearing in a specific pattern?

Check cables etc

It appears to show as a straight line on the middle of the screen where the image gets desynchronized.
This behaviour had happen even in Windows 10, 1 week ago(I haven’t played much to use my custom resolution). And at that moment I checked the cables and they appear to be fine, not a weak point or a pin broke or something else.
The two images should show how my issue looks like.

Mesa Git and the latest kernel, plus xorg.conf tweaks should get you up and running.

If it’s a recent GPU like Navi or Radeon VII, then wait for Mesa drivers to catch up. It’s easier to configure xorg.conf on Mesa.

But he’s experienced it in windows. I have to say that its something with his panel.

OP what model screen do you have?

Ah, I see it’s a custom resolution of 4:3 1080p. It’s a scaler problem. On Windows you can solve this by letting the GPU scale the image to the aspect ratio and pillarboxing the image.

I should also say that the issue appeared in Windows after I updated the chipset and the gpu driver(was included as an option with the chipset) and after the update I got some artefacts, full colorisation in blue/green/purple of the panel and this problem.

Well…the panel is a C24FG73 from Samsung.
The GPU scaling didn’t do much for me.
Also I’ve tried to use 1400x1080 and it works without any issue, but 1440x1080 it’s “cursed”.

I wanna say that, as seeing its a curved wide panel, its most likely 2 panels put together that aren’t synced correctly.

Dunno how to fix that. If a slightly lower res did it, then its probably something wonky on the controller. Your system is fine.

If that’s the case then an older driver could solve the issue with the scaling controller?
I mean on Windows, with 18.8.2 driver from AMD everything was ok, then the update have messed up my system . I would think that the latest drivers could have this bug even in Linux drivers.
Edit: the equivalent of the 18.8.2 driver could be 18.1.0 on Linux? it’s a difference of a few months…

Oof, thats out of my scale of knowledge. I’m going to say that it is the case, though.

I forget. What kernel is Pop on?

No clue.

@FurryJackman ??

The kernel is 5.0.0-21.

Well then I’ll assume as you have an amd card that itts sorta new? 5.0.0 is ok for most things, but I’d say you’ll want to update your kernel to resolve this.

As 19.04 is on kernel 5, not 5.2 (which is what I recommend rn for amd users at minimum) you might not have the tech in place at base to handle it, or its a bug in the driver attached to the kernel. Same could be said for windows.

I’m sorry that I haven’t written down my system specs till now.
My system is based on a R5 1600X and an RX 480 8Gb.
The 5.2 kernel has a limited support for older tech or something else?

Mesa versions are different from Adrealin driver versions. The latest Mesa is 19.2.x.

It will not interfere with Adrenalin drivers? I mean the drivers that are already installed on the system…