Pop!_OS; Steam Rights

I have been trying to to add my other drives to Steam Storage Manager, but I keep getting the same message over and over.

“New Steam library folder must be on a filesystem mounted with execute permissions”

I have no idea how to fix that, I have tried a lot of different things;

sudo chmod 1777 -R ~/Games/FAST
sudo chown querzion -R ~/Games/FAST
sudo chmod +x -R /Games/FAST

It says I have owner rights, but I can still not fix the problem.
What should I do?

fstab is set up like this.

Other Harddrives


UUID=804c957b-1d92-4e94-9dcd-8610e476b9fc /home/querzion/Games/FAST ext4 rw,defaults,noatime,auto,user 0 0


UUID=59cfb494-9180-4842-a25b-e028d166a382 /home/querzion/Games/SLOW ext4 rw,defaults,noatime,auto,user 0 0

If you use mount and ls -ld you should be able to see the status of your drive and the subsequent user rights, like so:

$ mount | grep sda1
/dev/sda1 on /mnt/extra type ext4 (rw,relatime)
$ ls -ld /mnt/extra
drwxr-xr-x 4 root root 4096 okt 23 17:54 /mnt/extra

What you probably miss here is that you want to make sure these are mounted with your user rights. Steam is running as your user and this is probably why you cannot use the directory. There are two ways around this:

  1. Mount the actual disk as your user (more complex and more prone to breakage)
  2. Add a subdirectory and redirect Steam to use that (much easier).

To do #2 simply create a new directory, make sure it has your credentials, and then point Steam to that directory:

sudo mkdir ~/Games/FAST/Steam
sudo chown querzion:querzion ~/Games/FAST/Steam
sudo mkdir ~/Games/SLOW/Steam
sudo chown querzion:querzion ~/Games/SLOW/Steam

When I was trying out Linux for gaming I had to format the partition and then have the drive / partition mount at startup not when the user clicked on the drive. The additional reason for having to format the partition was that some of the games wouldn’t launch if the partition was ntfs vs ext4.

I was able to get both items done thru gnome disks (disks thru the app store). I don’t know the relevant cli or other distro equivalent as this is what worked for me, a linux noob.

My $0.02 for what it’s worth.
Hope the info helps.

mount | grep nvme1n1
/dev/nvme1n1p1 on /home/querzion/Games/FAST type ext4 (rw,nosuid,nodev,noexec,noatime)

Should I just add exec in fstab then?

I usually use gparted, while the nvme is formatted and empty, I can’t do the some with my 8 TB since it’s half on half a backup disk. I need to buy a 4-8 TB external to use instead, or one more nvme for the sole purpose of gaming. 2TB with a total of 3TB 250GB should be enough to install games on, I think I counted it to be all my games installed 4TB in total, and I’m not going to have all games installed at the same time… Maybe…

The Drives now work with steam. I added exec in fstab and then chowned the disks. Done.

To explain what happened here, your system defaults to noexec for mounts as can be seen here (my emphasis):

Adding “exec” should do the trick, yes. Probably possible to do from within gparted too somewhere, but no idea how to use that program. :slight_smile:

1 Like

Well they work now without a problem. ^^ I should look up the trim parameter though… Arch was so much easier though. It would add those parameters to the main drive so I could copy it to the other m.2 stick.

I would love it if Pop!_OS not only made their own Rust Cosmic DE, but also created a KDE version, because I’m a KDE fanboy and I don’t get around in GNOME that well. I get crazy about how the damn file explorer won’t work as I want it to, and I don’t really want to install KDE stuff, I know how that would break a system back in the days.

I would also love it if a drop-down terminal was added to Pop!_OS that goes together well with the tiling, because I have tried multiple now, and they all kind of break graphically, or break the DE, so I have to restart, even had to do a refresh of the system, and after that Lutris will not start properly at all.

This happens…

Then it shuts down within seconds…

You could just have a large terminal and TMux as a workaround? :slight_smile:

I use the Terminator terminal, it’s nice, I also found one that had a drop-down feature that is built upon Terminator, but it lacked in settings.

I need to learn how I open Terminator with multiple tabs and splits from the get go though. I’m going to check a video on that. I learned how to do it with Yakuake, so I wrote a script, got a d-bus warning everytime it was run, but it worked perfectly well, and because of the warning I also knew that it had started. That’s what I use in Arch/Arch-based systems.

I always install Terminator, but I haven’t learned to use it well.

I reinstalled lutris now and added their ppa directly.

guake is a drop down term by default, it’s pretty good.

1 Like

Yeah I used that for other systems that wasn’t KDE/Plasma in the past, but I couldn’t install in through the Pop!_Shop. I don’t know If I want one right now anyway, it’s more in order to have multiple tabs from the get go, that can be hidden while I do all the other stuff.

I must have fudged up royally now…

❯ lutris
2021-12-01 19:38:25,950: Starting Lutris
2021-12-01 19:38:25,988: No cores found
2021-12-01 19:38:28,731: Startup complete
2021-12-01 19:38:28,732: Running X.Org Mesa driver 20.0.5 on Radeon RX 580 Series (POLARIS10, DRM 3.42.0, 5.15.5-76051505-generic, LLVM 10.0.0) (0x67df)
2021-12-01 19:38:28,732: GPU: 1002:67DF 1043:0521 (amdgpu drivers)
/usr/bin/python3: symbol lookup error: /usr/lib/x86_64-linux-gnu/libvulkan_radeon.so: undefined symbol: amdgpu_query_video_caps_info

Yeah, it doesn’t like the amd-pro drivers. Uninstall all pro drivers and install OpenCL only by calling:

amdgpu-install --opencl=rocr

This should take care of it, but no way to know until you try :slight_smile:

1 Like

Well, everything is working now, so I haven’t given it much more of a thought.