Pop!_OS is driving me insane with some broken packages

Hey all,

Sorry I joined the forums to ask for help, but I’ve contacted the developers directly, made about 5 reddit posts and troubleshooted as much as physically possible and attempted every fix I can. I’ve still gotten pretty much no where.

Currently, I’m trying to upgrade to Pop!_OS 19.10 from 19.04, and I’m getting a “failed to upgrade OS: failed status: failed to update package lists for the current release: command failed with exit status: code 100” error. When using sudo apt update in terminal, I’ve found that i386 packages are likely the culprit, as they’re returning quite a few errors you can find here:

(If you just want the terminal copy specifically, it’s here: https://pastebin.com/qsxwBcT1)

Can anyone please help me out? I feel completely abandoned by the developers and I’m too inept when it comes to Linux to really be able to properly fix things myself.

Any any all help would be appreciated, thank you.

1 Like

Ubuntu dropped support for i386 with 19.10 (with some exceptions). Source No way around that. So, disable that architecture, get rid of your currently installed i386 packages and get rid of the Teamspeak Repository that aren’t available.
Also: What are you using the SteamOS Repository for?

But, to be honest: Save your /home folder and reinstall. It’ll probably be easier that to pull out all i386 dependencies from your System.

Or: Just stay on 19.04. It’s an LTS release. You don’t HAVE to upgrade to 19.10


So you agree it’s i386 being the issue?

I don’t know why the SteamOS repo is there, I removed it after making that pastebin. I was really hoping to avoid formatting etc. but I feel like if some i386 files are needed then manually removing them is a recipe for disaster.


You don’t have to. As said, 19.04 is fine for quite some time. There is no need to upgrade to 19.10 now.
Overall, Ubuntu specifically and other distros in general are moving away from supporting 32Bit packages. So, sooner or later, this will become a “problem”.

You can start buy running dpkg -l | grep i386to see which 32Bit packages are even installed. Might just be a package or two…

You can also just run dpkg --remove-architecture i386 and see if it goes through. This will only work without error, if the architecture currently isn’t in use.
So far, apt is only complaining, that the Architecture isn’t available on some repositorys for you. So, might be you have no 32Bit Packages installed at all and Pop just enables it out of the box.

1 Like

Daddy, chill.

19.04 support probably ends in february, you have time. And we’ve all been there with linuxisms, don’t worry. Do as the german guy says and keep us posted.

1 Like

Yikes, so upstream Ubuntu changes still affect Pop!_OS. Hoping Pop!_OS 20.04 will have this resolved, otherwise, you have to stick to 18.04.

Hmm well I tried the steps you suggested to no avail, it looks like I’d have to remove the packages individually. I think I’m just going to format and start over.

To be fair, it’s probably for the best anyways as I at least understand Linux a lot better in the 2 or so months I’ve been running it as my dedicated desktop OS, so I know now to be more careful about the garbage I install. Thanks for the help anyways.

Please try to make an informed decision on wether you need 32Bit Libraries.

Steam, a lot of Games and similar stuff still depends on 32 Bit Libraries to run.
If you need those, you might want to choose a different distro than Ubuntu (or any that’s based on Ubuntu).

Could you post the list of currently installed i386 packages on your system?

If you’re looking to game and have a better understanding of Linux, though I’ll regret saying it, Manjaro is looking good in terms of community support if you get stuck, and doesn’t have the 32bit issue.

I remember system 76 stating they’d still cater to 32-bit packages… how will they do it?

Will they get to a Debian base instead?

Does taking 32-bit away means no Steam?

That’s the plan, but with 19.10, they seem to be depending too much on the original Ubuntu repos, causing this breakage. This doesn’t inspire faith that the problem will be solved on Day 1 of Pop 20.04.

They do. The Problem here isn’t that certain packages aren’t available, but that i386 is specifically activated as an architecture through dpkg. This means that apt update will look for i386 compatibility in all Repositorys you have configured. The bunch of “Errors” OP is getting is just apt telling you that those repos don’t have i386 as an architecture included.

Not necesarrily, but at the moment, yes, mostly. Valve is working on that. Same with Wine. But they aren’t there yet.
I’m on 19.10 at home, so can test later, but i’m sure the native Steam Client will at least install. But at most, i’d suspect Proton won’t work. Since that’s all relatively fresh, i can’t say for sure though.

For now, for anything gaming i’d recommend another distro. Debian, Fedora, Manjaro are all great choices that don’t have similar issues (for now).

I’d avoid Fedora for it’s weird Xserver quirks. Manjaro has the best community support, and Debian is a fairly barebones start, so be prepared to configure a lot.

You can select on Installation how much/little you want.
The only “downside” i’d say is getting Nvidia drivers to work. It’s easy, but certainly not to the level of Manjaros gui application.

But yes, Majaro (preferebly KDE :wink: ) is a great choice.

19.04 is not an LTS… 18.04 is. Next LTS is 20.04. Also, I suggest people stick with Debian or Manjaro.

1 Like

Wow sorry I’ve been lax on my replies, I underestimated how active and supportive this community would actually be.

As a result of not checking these forums I formatted and installed 19.10 fresh using a bootable drive. Interestingly I’ve had no issues with proton nor lutris, having just run war thunder with dxvk support. Not sure if System76 has done anything under the hood to make sure things work with 19.10 but I’ve had no issues so far. It’s also nice usi v a fresh install with none of the garbage I added previously.

Are there recommended apps with a nice GUI to help me manage repos and packages just in case? I’d do things from the terminal but I’m not sure I’m quite there yet

You are correct. Sorry for the misinformation.

To be honest, on anything *buntu i just use gnome-software. It works well enough for most basic stuff. Installing/Uninstalling Software, Enabling and Disabling Repos and you can install repos by just opening the repo file in gnome-software.
Haven’t looked into more alternatives as i move to the terminal if this doesn’t suffice. But gnome-software should get you 95% there.

Beware that War Thunder DXVK and Wine support will end as soon as Easy Anti Cheat is active, then you have to wait on Valve Time for EAC to work in Wine again.

Whilst I assumed the same, one of the devs on the forums stated that running dxvk he had no issues in the official thread, so there’s still hope.

Yes, because it is currently disabled due to bugs with the EAC implementation. They do plan to eventually enable it though and once that happens, you’re screwed.