Return to Level1Techs.com

Pop!_os black screen with auto login enabled

#1

Pop!_os 18.04 with nvidia driver on a gtx 980ti works fine but if I enable the auto log in it won’t start the desktop environment and the screen is black.

0 Likes

#2

Hmm interesting issue…

Execute sudo nano /etc/default/grub and add the parameter nvidia-drm.modeset=1 acpi_rev_override=1 to the line GRUB_CMDLINE_LINUX_DEFAULT . Save the change you’ve made and run sudo update-grub .
Restart the POP OS operating system, and now, everything should work properly.

What hardware is it running on? Like other info about the system

Did you install the NVIDIA drivers as such:

sudo apt-add-repository -y ppa:system76-dev/stable
sudo apt-get update
sudo apt-get install -y system76-driver system76-driver-nvidia

Or did you install it the proper way by downloading the nvidia image version of the OS?

0 Likes

#3

I will try that now, everytime I tried it I simply reinstalled the os, is there a faster way back? System is Asus P9X79E-WS with Xeon 1650v2 and 32GB of 2400Mhz ram.

0 Likes

#4

https://pop-iso.sfo2.cdn.digitaloceanspaces.com/19.04/amd64/nvidia/5/pop-os_19.04_amd64_nvidia_5.iso

0 Likes

#5

Sorry I forgot the driver part, I didn’t install any driver, I just installed the nvidia pop os iso with 418.56 driver version. Is that not enough? It also looks like (from the gnome-software-tool) that I’m not using X.Org but the open source driver metapackage.

0 Likes

#6

Adding those parameters to the grub didn’t work:(

0 Likes

#7

Got your pm. Its no bother. I just got preoccupied… Anyways hmm this I’d interesting…

Try nouveau.modset=0 in the grub

0 Likes

#8

What I’m asking is: is there a way to avoid reinstalling the os from scratch now that I get the black screen?

0 Likes

#9

Well your gonna have to consult the logs to see whats up… try appending a 3 to the end of the grub command area to see if it still locks up in init 3… I suspect it wont

0 Likes

#10

I don’t know how to explain, I have no idea how to do anything now that I get a black screen.

0 Likes

#11

so, if you disable auto log… will it run ok?
if anything you could use 19.04 also, might have been fixed.

1 Like

#12

I have a bit of a suggestion. Start with something simple. Im going to guess you do not have very much linux experience. So my recommendation is grab either Linux Mint or Fedora (I use fedora) and step by step install stuff you need. Go to wikis … learn the CLI (command line interface). You see if you do not have much linux experience its hard for us to help you diagnose the issue

0 Likes

#13

I’m not the master of the command line for sure but I’ve been using different distros of linux in the last 5 years using the command line. Probably I forgot to learn the shortcuts to boot directly to the cli maybe, I’ll try to install the 19.04, I love Fedora too by the way, I just wanted to try Pop os for VFIO thing.

0 Likes