Please Help Asus Crosshair viii Extreme Thunderbolt 4 not working

Don’t know if anyone can help i cant find anything anywhere about how to get the Thunderbolt4 working not even the Power Delivery (yes the extra 6pin is connected)

I’ve been trying to get me GPD WIN 3 to connect over Thunderbolt but nothing infract it dose not even deliver power nothing.

i am using a intel certificated thunderbolt 4 cable.

i have also tried my eGPU and it dose not see it at all.

There is nothing on asus site about the thunderbolt on the crosshair extreme just a mention it has it, I am completely stuck

I have the same problem
I don’t know what to do

the main reason I bought the motherboard was the thunderbolt that dose not even seem to work

Have a look in the Thunderbolt General Help Area thread to check some UEFI settings:

I did all the steps described in that post. However, C8E’s BIOS for Thunderbolt security has only two options, which are “No Security” and “USB4 Only”. After re-installing Windows 11 build 22000(21H2) twice, the PCIe tunneling is still shown as disabled. BIOS revision is 0801 (latest as of now).

After speaking to ASUS support team and going to one of there services centre they didn’t have any answers at all and confirmed these nothing wrong with my board they even tried the thunderbolt ports on a brand new board they had in stock starting to think that it has not been enabled fully

So it sounds like ASUS has just given up on this idea? I’ve been struggling with one of the two ports not working for months and only now am I really sitting down to troubleshoot it as I need a 2nd port. The top port works but the bottom port (closest to the PCI slots) does not. Is that what you others are finding?