Return to

Play games in Windows on Linux! PCI passthrough quick guide



I'm only using one gpu, and switching between Windows and Linux.


Thanks, I'll try that.


You better don't try at all, you need 2x gpu to make passthrough, and if you blacklist nv drivers now you gonna have to use terminal only (if ubuntu in recovery mode) to unblock drivers so you can use gui again, maybe even in live with alt+f2 or something.


Is there anyway I could use only one GPU? bc I have a second one, I just thought I'd give a try with one.


So, are you talking one dedicated gpu or one gpu total?

If you set up your Linux host to connect to your iGPU, and blacklist drivers on your dGPU, you'll be able to do it.

I can confirm it's possible to use one GPU, but that's getting damn close to the bleeding edge of this technology. I'm working on a guide for that, but it's probably going to come out in March or later, since it's so difficult to reliably do.


That'd be cool, I'd definitely watch. I only have one GPU total. I was just thinking about switching between Windows virtual machine and Linux.


I've been having trouble with this because I'm at the point where I need the PC I'm testing this with to do actual work, so I'm constantly rebooting into another btrfs subvolume.


I hope you can find a way, bc I really wanna ditch Windows (somewhat ditch Windows).


I'll keep you updated.


So, I put a second GPU in and blacklisted the nouveau, then nothing showed up on my Nvidia GPU. So, I tried removing it from the blacklist, and nothing showed up.


You need to make sure that your bios isn't starting the nvidia gpu you're trying to pass through.

Also make sure that you've got the id of the gpu being passed as a kernel parameter to vfio-pci.ids=


Thanks for the help, my Nvidia card is now VFIO!


Perfect! Glad to help.


I'm also trying to get it to work on openSUSE, could you tell me how you had your initial boot device set up and where you got your ISO from?
I have tried it with many somewhat questionable ISOs with varying degrees of success but on VirtIO or SCSI I end up staring at the windows logo for 10 minutes only to notice that while the animation is playing, nothing is happening. Only IDE actually allowed me to even install windows at all.


I didn't have any issues using any of the options except virtio where I had issues finding a driver windows 10 liked. I used the ISO Microsoft was distributing on their site at the time. I even dd'd an existing windows install to an IMG and used that fairly successfully.


For the record, the best place to get the virtio drivers is from the fedora page. Download the ISO and mount it on a SATA drive in the VM.

direct link to latest


Indeed however Windows 10 requires whql signing or some nonsense


I'm pretty sure these drivers are WHQL signed.

I've never had an issue with those drivers.


Thanks a lot for the great guide, finally got it working flawlessly on openSUSE 42.2.
Q35 was very unstable for me so I tried again with I440X and while stable, I still had some issue with my GPU where I had to uninstall the Windows "Microsoft something something graphics adapter" to even get the AMD installer to recognize my hardware and get a resolution above 2x2 pixels.
Overall your guide was a very nice red line to follow along with, thanks for your effort!


They used to work for me as well, maybe I just got a bad batch. Didn't really have the bandwidth at the time to try again.