Play games in Windows on Linux! PCI passthrough quick guide

Take a look at this for laptop gpu passthrough- https://gist.github.com/Misairu-G/616f7b2756c488148b7309addc940b28

Hey all. Thought I’d revive this thread with a valid question; is this guide still relevant with the steps shown, or have things changed since this guide was created? Has it been updated?

I’m planning to do this with with my new build (2700X, X570, 16GB, GTX 650Ti boost & RX 570 GPU’s) and have been looking for a good, detailed how-to guide.

Thanks.

Not sure about the instructions here but I’ve followed those over at VFIO in 2019 – Fedora Workstation (General Guide though) [Branch, Draft] and it mostly works. Check the comments for some specifics.

Ok, thanks. I’ll check that out.
Also, are the steps basically the same for Arch-based distros? I prefer to use Manjaro.

Thanks.

Success!!! :smiley:

2 Likes

Alright, everything’s working well. Just one thing I’m having trouble figuring out…
I want to use the front panel audio for sound with the Windows VM. I tried adding a hardware device, sound > AC97, and it appears there is an output device showing in the VM, but I get no sound from it. Still searching, but haven’t found a solution yet.

Any thoughts?

Thanks.

I have the same keyboard. Corsair ftw!

1 Like

Sound should “just work” if you choose the right output. I really found it hit or miss, so got myself a cheap used usb sound card, and pass the USB port through, which takes the card with it.
The sound had been working on ich6(or something) then stopped, then worked on ac97. Then stopped.

There is a thread about using SCREAM or some such, but I already had the device :man_shrugging:

1 Like

Ok, thanks. I’ll keep experimenting with it.

1 Like

Ok so im having a weird problem, i got lspci reporting that the card is using the vfio driver but when i create the vm im dumped into a SHELL> rather than it starting the windows installer… so i type exit and then it brings me to a boot options screen where i select the windows installer dvd and the screen goes black for a second then returns me back to the boot options…

Hello! I am currently stuck in Debian 10 while patching acs, as i drag the patch over and press enter, it gives this error: patch: **** strip count l is not a number

If anyone knows what can be done to fix this, plz respond.
thx

Try using a version of the patch for the newer kernel found in debian 10. You can find your kernel version with uname -r.

This one is for 4.19-
https://gitlab.com/Queuecumber/linux-acs-override/raw/master/workspaces/4.19.5/acso.patch

Hello, did you solve it? i have the same 1080 and passthrough is done. but can’t start FIFA 19 or FIFA 20 Demo.

Thank you for putting this guide and video together!

Is this guide still (mostly) valid in January 2021? Is there a more recent guide around?

I have 1 GPU and no integrated GPU. I am thinking of passing the GPU and various USB ports to the guest OS and then simply control the host via SSH. Is that generally viable?

It’s possible, viable depends on your use-case, but generally not recommended. You get none of the benefits and all of the negatives vs just dual booting at that point with just one card. A cheap host card is definitely recommended even something like a 50$ gtx 710 would do.