Ping and DHCP

does the state of DHCP enabled or disabled play a role if a ping is successful toward these major site, like google, youtube, amazon. etc.?

The VM (virtual machine) i was using to ping sites was successful. But, the DHCP was disabled. So makes me wonder if it's possible the DHCP plays a role in if a ping is successful.

This is related to Network.

DHCP (Dynamic Host Configuration Protocol) is a network protocol used to configure network interfaces that support getting their config from a so called DHCP server (IP, Netmask, Gateway, DNS,...).
If your VMs networ is statically configured (as of you manually set the IP, Netmaske, Gateway and DNS) than you do not need DHCP.
That you were able to ping google tells me that a) your NIC is configured and b) DNS is working.

The DHCP is what hands out your dynamic ip address on your network. Its possible you have two DHCP servers running on your network and if the wrong one hands your computer or vm an ip address that can't reach the internet.. well then you cant reach the internet.

If you have an all-in-one router/modem thing from an ISP AND a wireless router on your network, you will need to either disable DHCP on the ISP device and give just your router a static ip, or you need to put your router in access point mode which basically disables DHCP on the router.

When i try to ping google on my personal computer it's is slightly successful, but i still get a "timed out message" reply, but i do get that google has 32 bytes of data. The thing is i then ping my computer with and it works fine.

It is successful for let's call them smaller sites like let's say I get a reply back that tells me the TTL


That is the loopback device... that is your local computers local address. That will always work. If ping only times out for the mayor sites but not for others the problem is a little more delicate it seems.

if you open the command prompt (CMD), what does ipconfig /all return?

My network+ book said that if you get the timed out then you have check self through the loop.

I thought that maybe the major sites are rejecting my request echo.

Tells me my hardware.

it returns (2) tunnel adapter, ethernet, Lan wifi and local area connection, bluetooth, then my Window IP configuration

That is the interesting part. So you get a valid IP assigned via DHCP or have set one manually that is valid on your local network? Well does reply to ping requests for me.

well i am pretty sure it it DHCP assigned.

My friend ping google and got the same response (time out" message). So scratching my head. I am wondering if something is just not configured correctly.

My DHCP is disabled i believe on my tunnel adapters. So not sure if that is an issue.

if your DHCP is disabled then how is your device getting its ip address? is it a static ip? if not try a release/renew.

if it is, check that your settings are configured correctly. Try changing your DNS settings to googles addresses.

Is that friend on the same network as you are? can you access through the browser?

i can access google through my web browser. And my friend is not on the same network as me

I'll try the release/renew and see if that helps.

Did the release and renew and i still am unable to ping google. I'll check the DNS setting

Well if you can access it otherwise, and its only a view sites you can not ping... well maybe.. maybe google has the servers nearest to wherever you are from to drop ICMP ping requests... or a router of your ISP does that... a


Could also be tried, that will ping each hop between you and google. Maybe that shows where the ping is stopped

I did that and i am getting stuff for 1 and 2, but 3 and after i get nothing.

Than station 3 is blocking ICMP echo requests... that’s it. How does the tracert for the sites look that you initially could ping?

Seems to be going through smooth for the tracert... I am getting response back that goes from 1-9 after the 9th the tracert is complete. The google one even at the 19th it kept getting the same fail response. so i had to control-c to end command.

May i ask... what would be the reason for station 3 to block ICMP echo request

Settings... may sound like a stupid answer.. but the why its setup like that.. i have no idea