Pfsense + TrueNAS - NFS issue different subnets. <('.'<)

Hello everyone :wave:,

Good day to all. I am a normie in need of help, not sure what I am doing wrong. I have a pfsense box separated from my truenas box (no vm magic :magic_wand:). My pfsense separates three sub networks, 1 for my LAN, 2 for WIFI and 3 for my servers (only a NAS :cry: ) with separated NICs and different IPV4 addresses. I want for my LAN to access the server one. The issue comes with NFS (havent tried SMB), I can connect and start seeing a movies, but then it freezes ( :cold_face: ) and drops the connection.

Checking my rules, I made for all traffic from LAN to pass-through to Server and vice-versa. Am I missing a config or something?

I will try my best to provide the info you need to solve this mystery.
image

Thanks for the help.

LAN Config

SRV Config

Your network rules look OK to me, but on the LAN settings why are you denying DNS traffic to the pfsense? I don’t think that’s the problem, it just looks weird to me.

Your rules are redundant, but shouldn’t be causing a problem. The rules you have for specific destination networks are unnecessary because there’s an allow any destination rule at the bottom.

Tell us about the separate NICs you’re using, are they USB NICs?

If you can connect, then it’s not firewall rules blocking it. How long does it take to freeze/drop the connection?

Thanks for the reply :smile:. The NICs are not USB, they connect through PCIE. These are the cards I have:

HiFiber for Broadcom BCM57810S Controller 10 Gigabit Ethernet Sever Adapter Card, Dual SFP+ Port

StarTech ST20000SPEXI Tarjeta Adaptador de Red PCI Express Ethernet 10G, Base-T con 2 Puertos RJ45 Chipset Intel x540

The NAS is connected to the HiFiber and the LAN to the StarTech.

Regards.

It freezes :cold_face: after 1 minute. Then the connection drops.

Made another experiment. Connected the NAS on the same networks as the LAN and it works. Only when connected to my pfsense box, is when the connection freezes. Making me believe the culprit is the router (not sure though).

imagen

So what’s the CPU like for your pfsense box? Because all of your traffic has to go through it when they’re on different networks.

Try checking the system logs on pfsense when the drop occurs, I would be a little surprised if it’s the cause but also 10G cards can quite hot without direct airflow and especially under heavy use. I wouldn’t really consider a single movie heavy use though which I don’t think it’s that.

imagen

1 Like

Hi everyone, found some option to tinker with. But no success at the moment. Do you know if there is a guide on how to configure pfsense for NFS?

That CPU should be plenty, just wanted to check it wasn’t some crazy low spec Intel Atom or something. Did you configure an routes manually? They should have been automatic.

This really feels like a hardware issue to me. To the googles.

OK, I can’t find your startech card or any Intel X540 chip card on this list. I can find a Qlogic card with a similar chip to your HiFiber card. This might just be a hard compatibility issue.

Can you try a different NIC for the NAS network? A 1gigabit whatever would be fine. Just something else.

Sorry for late reply. Unfortunately, I changed the NIC as suggested and no luck. It still freezes after 20 seconds aprox. :cry:

Genuinely perplexed. Try disabling transmit and receive offload? Maybe the NIC is doing something weird. I think that’s usually disabled by default though.

If the issue doesn’t happen when your NAS and your client machine are in the same subnet, then why not just give your NAS an IP address on the client subnet? If all of the network traffic can stay level 2, it will be a bit more efficient and less resource intensive for your router. You can run a firewall on your NAS and still keep it just as secure. This doesn’t truly solve your issue, but it might be an issue you don’t really need to deal with if you slightly change your network design.

1 Like

@jorheccou Have you tried to use what I call movie management software? Setting up an Emby or Plex server for your movie collections might fix your problem.