PfSense OpenVPN IPV6

I set up a VPN client and got everything working with the interface and the firewall rules. When I check my ip on one of the devices I have directed through the VPN the IPV4 address is the correct VPN address but the IPV6 address is showing my ISP. I made a firewall rule to block all IPV6 on the interface and restarted the device I was testing on but I don’t think that worked. Is there a way to prevent this from happening? I thought about just completely disabling IPV6 in PfSense to solve the problem. Is there any downsides of complete disabling ipv6?

If you’re not using ipv6, it’s fine to disable (if not a good idea to do so).

Cool. That worked, Thanks.