Return to Level1Techs.com

Pfsense broblem


#1

Hello,

I have broblem whit pfsense box. Some reason pfsense will crash after few minutes of use.
No crash log entry nothing.

All ready changed buffer size and try every bossible settting but no help!
Any ideas?

Amd e1-2500
4g Ram
intel PRO/1000 PT Quad port server adapter


#2

What version of pfSense are you using and have you recently updated? the newer versions have moved to php7 and if additional packages were updated prior to the update it could cause it to partly fail with instability on the system such as crashing


#3

Web search says your using laptop?
Is cpu thermals an issue(put 4 soda bottle caps under laptop to give more intake air room)
Note hd8000 gpu shares ram with system
Also note laptop usb port used as it could have 2 types and what adapter are you using (usb to pciex slot?) as your not gonna get 4gbps and could be overflowing the usb buffer or adaptercard.
You don’t say what type reset(full crash or just network) so?


#4

I had a J1900 setup that would crash a lot and it turned out that Intel has a flaw in that chipset. There was no crash log as all compute craps out. For other trouble shooting, there was free software (forget what it was called) that is a live boot you put on a USB to then test the RAM (if its a RAM issue). @gamer8493 brings up a great point too, could be thermals. I just re-potted an old HP laptop, it went from almost un-usable and hovering around 80c to whicked fast and always around 40-50c.


#5

thanks for answers! :slight_smile:

Its not laptop but some lenovo mini pc whit intel PRO/1000 PT Quad port server adapter 82571EB on pcix16 lane. pfsense just boots suddenly whitout any log input or anything.
I updated to latest version 2.4.4 in the beginning maybe that is the broblem? I try older when i have time. My older pf box runs whitout any issues on newest version but it sucks little too much power so i look some alternative. I run memetest86 it passes whitout any issues so i dont think its ram and cpu temperatures is 50-70 all the time.

I installed debian to that same machine just to test what it does and it has no problem what so ever.


#6

First off: pfsense isn’t linux based, it is bsd.

Depending on what features you need, maybe give ipfire a shot.


#7

yep i know…

ipfire wont bond wan connections. I tryed it in past it was nice waiting for version 3.


#8

Hmm still might be heat
My old athlon64 was 65°C cpu max thermals so id double check your cpu specs of tolerance ranges

Is this right?
http://www.cpu-world.com/CPUs/Jaguar/AMD-E1-Series%20E1-2500.html


#9

yes, gamer8493 thats right prosessor.

I tried the older version and still doesent work so… I installed minimal debian and kvm. Now its perfectly happy to run in virtual machine i know maybe isnt perfect but now its working for me.

Thank you all…