Return to Level1Techs.com

pfSense and port forwarding "Incoming TCP" port for uTorrent

Hi all-

My current setup is like this

ISP router ------port forward or "DMZ" (DNAT) ------> pfSense (WAN)

I’ve set port forwarding in pfSense which auto-creates a firewall rule to open the port in question. Tested this by opening port 222 out to the WAN and SSHing into a local box. This worked fine.

However, when I opened a port and set that in uTorrent – I get “Connection unavailable”. What am I missing here?

On the ISP router side, enabling “DMZ” means all WAN traffic now hits my pfSense’s WAN interface. This isn’t entirely needed, and I can also double-NAT the same port over as needed. I can get this to work with SSH but not with uTorrent. I tried allowing TCP/UDP on the same port as well.

1 Like

Figured the issue – My ISP router doesn’t play well with regular port forwarding, so I went with its implementation of “DMZ” (or DNAT everything to my pfSense’s WAN interface).

Since I’ve for a VPN gateway in pfSense, that too needed a port-forwarding NAT rule for the incoming TCP connection for uTorrent.

If any admins see this, please close this thread - thanks!

4 Likes

Closed at OPs request.