pfSeense bootable USB issues

For the past two days I have been running into a strange issue with re-building my pfSense router. On my particular hardware: old Dell XPS630i running an Intel Core 2 duo E8400 CPU @ stock speeds of 3.00GHz and an ATI R3600 GPU, with 4GB DDR2 RAM. Previously I was able to somehow get pfsense onto a usb drive using YUMI, but as of late I haven't been able to use that for some reason. The following are all the options I have tried to get pfSense-CE-memstick-2.3.3-RELEASE-amd64(i386).img onto a USB drive so I can boot off of it using either an old USB 2.0 4GB flash drive or a newer 64GB corsaird survior flash drive:

  • Downloaded both the 2.3.3 memstick amd64/i386 versions
  • Also downloaded the ISO file of the same version
  • Downloaded Rufus 2.12/Win32DiskImage/linux-debian-dd-gzip command on the pfsense website
    * Installed debian onto the Dell system from the Corsair flash drive (just to check my sanity and make sure it was being seen)
  • Wiped the drives before each attempt
  • Drag/dropped the .img files into rufus and used the defualt settings/DD option
  • I am able to load a USB 3.0 YUMI based flash drive, that has a few troubleshooting tools on it just fine on the Dell system** (see not below)
    **Tried to use the ISO with the 2 USB drives and all the programs, even YUMI but it keeps failing. Since it's an ISO why would it be acting differently, I have used YUMI to get ISO files of macrium reflect, winPE, win10 ISO and even DBAN onto a USB drive and it boots fine on all my systems, including this Dell system.
  • I have three different drives that I have used to try and get pfSense onto with the Dell system, but I keep getting into a bootloop with two of them. (the one already has debian on it, see above)
  • Just a few weeks ago when I tried installing pfSense onto this machine I was able to get to the splash screen and it would start the install until I got an "error 19" message that might have something to do with this new issue. Then I mistakenly overwritten the USB drive that HAD pfsense on it, which was able to be booted off of
  • I was able to get just the blinking "_" symbol with one of my attempts but nothing happened after that, not sure how/why/what I did that got it that far.
  • I have tried using all my USB ports (before you even say it, YES they ALL work), I tested each port within the debian install to make sure the USB driver were in fact showing up along with my keyboard/mouse.
  • Tried various SATA cables from the mobo to HDDs/other SATA ports, which all are working just fine becuase when I connected all 3 drives I could see them all inide the debian install.
  • I think I turned off all the features I could including but not limited to: Virtualization, ACPI set to S1 instead of S3, "Drive A" (Floppy drive), auto restart, can't change HDD settings from AHCI to ata or vis versa (drives are connected via SATA cable/see above).
  • According to dell and my service tag number I am running the latest BIOS version that my hardware supports (as far as I know)

Sorry for the long post, but I thought it prudent to mention all the steps I took, I may have forgotten a few, but that could just be due to the past 48 hours of hell I have been through trying to get this to work. Should also mention that when the first pfSense video went up on the previously named channel, I was able to get this same system loaded with pfsense, but I never did anything with it because at the time I had no control over the network I was on. Somehow that was how I was able to use YUMI to create a bootable drive.

Any and all help would be appreciated.
Sorry if this is in the wrong thread (admins, please move it if needed)

I've never used YUMI... but I have used Rufus. And while I like Rufus, you can do things with it that work against you.

Since you got your bootable Debian to work from the Corsair USB, I'd boot from that, download the pfSense ISO with it, and use dd to write the 4GB USB drive.

dd if=pfsense.iso of=/dev/sdb bs=1M

It sounds like your USB writing program is trying to do floppy emulation or something. Whatever it is, just use dd and it should work.

I will give DD another shot via debain and the iso this time. I'll let you know if that works.

It should. If that doesn't work it's a hardware thing.

Turns out that it just might be something with the newer versions of pfsense and/or the freeBSD version it is using. I tried using a few differen PFS images and a couple different USBs, but non are working on my hardware. Kind of odd since, like I said in the OP I was able to atleast get to the PFS bootloader and it would start installing. On top of all that I did double check each USB drive with a different system and they are working just fine. Linked are the screenshots of my BIOS, just in case I may have missed something that needs to be changed:

Reset all the bios settings to default first?

Or just say screw it and hook a SATA CDROM up to it for the install. Dunno what else to tell you.


Yeah, my next steps are to find some CDs and burn the ISO onto them, becuase for some reaosn pfSense's ISO is not like everyother ISO out there, where I can just burn them onto my USB drives.