PCIe bus corrected error message at system boot PLZ help!

I have this problem that occurs on literally every linux distro that I tried to install (Fedora, Ubuntu, Arch, and many others). I am pretty new to the linux world and I am interested in moving away from windows to Linux due to a lot of annoying problems in windows and because I wanna be in control of everything in my pc.

I get this problem on my boot screen everytime i boot linux from a usb stick installer or when I actually boot from a hard rive that has linux installed on it.

My systems specs are:

i7 8700k
Asus z370-e
sasmung 970 evo ssd
850 evo ssd

The settings I changed in bios inorder to try to fix this was:
Disable fastboot
Disablle secure boot and change boot option to other os
Disabled ASPM (Was disabled by default)
Disabled asus MCE
Try 4g decdoing off and on
Tryed CSM off and on

Non of this fixed the issue

I heared from alot of threads that this issue can be fixed by going to grub and turning aspm off or disabling the error reporting in boot.

The reason why I dont want to alter my grub menu settings is because I want to actually find out the root of the issue, and how to fix it properly.

Does this mean my computer has a problem because windows 10 runs great??

Do I need to wait for a bios update??

Is this normal on the coffelake ??

I know it is alot of question but it would be nice of you to really explain to me how to fix this!!!

1 Like

What is the issue exactly you go from happens on everything to your specs unless i ma missing something

“PCIe bus corrected error message at system boot PLZ help!” whats the specific error?

Also have you tried reseating the cpu

also try


these are shot in the dark without the exact error