PC Won't Boot

I was running beta graphics drivers and I was having some problems with Battlefield 3 crashes so I went back to 13.4 drivers.  When I rebooted my resolution was stuck at 640x480. I went to reinstall them and I can't do it because it doesn't fit on the page.  I went to redo Windows but I can't get into my BIOS (black screen).  Tried to get back into Windows but is only getting black screen and I have pushed enter a lot incase it was Windows rebooting incorrectly.  So all I can get is a black screen and i get no debug codes form my motherboard.  Have tried booting with APU and graphics cards, neither work.What should I do?

 

PC

A10-5800k

AsRock [email protected] Extreme 6

2x Radeon 6950 1gb

16gb Corsair Vengance 1600mhz

P.S I do know my money isn't in the right places.  Re-doing PC when I have the money.

did you also tried to boot wenn taking out the gpu´s and only use the onboard gpu?

try to reseat the ram. also try with one ram stick both ram slots, and also with the second ram stick both slots, also check all the power cables, cpu 4 pin power connector.

Are you getting a BIOS beep during boot?

I have tried both onboard graphics and my graphics cards and both of them by themselves.  I have done each RAM stick by themselves and it makes no difference.  I am getting no beeps.  The error code on my board is 99 which means something is wrong with the PCI-E lanes but I have taken everything out and I'm still getting that same error.  I formatted my SDD in my freinds PC then I plugged it in and it worked to install Windows and I did.  It restarted after the instillation and I now have the same error as before.

Do you have any jumpers on any pins that shouldn't be there? Remove the graphics cards again and connect to the onboard VGA and attempt that, if you've done that can you get into BIOS?

If so, change your settings so that the oboard graphics is the default then attempt to boot to windows. If you can't see your BIOS lets try to reset your bios just for fun and see what happens. Use a jumper, or remove the battery to do that. If none of the above work, I'm not sure where to go from there other than replacing the motherboard.

 

Edit: Also try installing one GPU at a time.

I cleared my cmos and my error code on my motherboard is now 2b.  2b isn't in the manual so I'm awaiting the responce from Asrock Support to see what they have to say.

You could try to do a full bios reset but I don't think that's your problem at this point, I'm starting to think you have a fault MB.

According to Asrock error 2b means it's broken.  Sucks for me

 

Damnit

Good news, now you can upgrade to a non crappy brand by getting an R.O.G MB.