PC wont boot

Sometimes, when I try to turn my pc on, it wont boot, mobo leds will turn on but nothing will happen once the power button is pressed.
I also tried to press the power button on the mobo but it wont turn on either.
PSU works if I stick some paperclip linking the green and black wire.
Sometimes, removing the battery fixes it, although the other day a bios updated fixed the problem for some extended period of time (2 months)
I'd like you guys to help me identify the problem, thanks!

We need more details than that, man.

 - All hardware details (motherboard brand and model will tell us quite a bit)
 - Last thing you did before the problem started?
 - How old is your rig?
 - Have you been fiddling with the hardware recently?

Let's fix this shit, broski.

ASUS IV Extreme x79 Rampage
3930K CPU
16gb gSkill Ram 1600 mhz

xfx 1050w 80+gold psu

Last thing I did before the problem started? Nothing it just happened randomly as far as i can tell.
and my rig is only 6 months old.

Remove all but one RAM stick, then try it. I just read that RAM is a bit touchy on X79. Especially if you overclock it (even the tiniest bit).

Yeah, I tried, but it doenst work.  When I remove the cmos battery it kind of works, idk how or why but it does. It's a really complicated issue if you ask me, cause the system works perfectly fine, it's just the booting that is getting a bit annoying or not working properly.
Also, it happens like what, once every month or every 3 weeks. 

So, when you press the power button, do the case fans and graphics card fan(s) turn on as well?

If so, do they stay on? Do you get any kind of image on your monitor? Does it say that there's no signal or something like that?

Just trying to narrow the possibilities. =U


As I stated up there,  as I plug it to the wall the mobo leds turn on, when I press the on button nothing will happen, no spinning fans, nothing, abolsutely nothing, just hte mobo leds being on, but those are on as soon as the computer is connected to the wall. 

Let's take a look at those LEDs. Colors? Number of them that are on? Are any of them labeled?

Those LEDs usually serve as a way of identifying problems.

No, not the Error Debugger, but the mobo leds like power and all that kind of stuff

It's very possible that your board is just dead. Many, MANY people have had to RMA their Rampage boards because of spontaneous failure (Asus' quality control is just super, sometimes). But, I'm not lazy, so I'm not going to give up.

Try another battery. A dead / weak battery won't stop your computer from booting up, but it never hurts to check.


Also, I see that your PSU is modular. Check. Your. Connections.

All of them. On the PSU and the board. Unplug them and plug them back in.

OKay well right now its working perfectly fine, but I will try that whenever it happens.

No problem, man.