PC Issues After Freeze

Earlier today my PC froze. I was updating Splinter Cell Blacklist from uplay (came with my 760) and it froze. I hit the ON/OFF Button, and it didn't turn off. I hit the reset button, and it turned off, and then on, but did not post. It would just stay on. YEsterday I moved my PC from my Antec 900 to my new Fractal Design Arc Midi R2. Every cable is plugged in similarily to how it was (juggled the SATAS around for cable management), and it worked until my update. I removed my GPU and tried a GT 640 and the onboard graphics, but i still didn't see anything on the screen except blackness. I also tried taking the ram out and only using one stick of ram, but that didn't work either. I even tried unplugging most of my fans to reduce the power load (even though I've got a 750W PSU and am nowhere near using that all). I plan on trying an i3-2100 tomorrow on the board, but I'm wondering if there's a trick i'm missing or if someone can give input.

EDIT: Windows 8 was reinstalled after switching case



Intel i7-3770k w/ XIgmatek Dark Knight Cooler


MSI Z77A-G45

OCZ Agility 3 120gb SSD & 1.5TB Seagate HDD

16GB (2x8GB) G.Skill Ripjaws X Memory

for a more detailed, but less current specs list look at my profile

tried reseting cmos?

Remove your hard drive power cable, and attempt to turn on your computer. If it posts, plug your hard drive power cable back in. If it doesnt boot/post once you plug in your hard prive power cable, try to reset cmos.

i tried multiple times

Tried unplugging HDD, SSD and ODD; still won't boot but it doesn't go in a reset cycle. It will just stay on.

Also tried resetting the cmos. Same results.

Tried my RAM in another computer, RAM is working fine. 

I plan on trying my i3-2100 in it later today to determine if CPU or Mobo.

Just got back from an interview- came back and tried some spare ram and yeilded the same results.

Also tried spare ram with my 640 & 760

Tried i3-2100 with:

no gpu/GT640, 0/1/2 sticks of ram, all/no ODD/HDD/SSD


still not working. I guess i'm going to have to RMA my mobo


Could be a short on the front panel, have you tried booting without using the switch's, disconnect all the front panel switches and just short the pwr jumpers with a screwdriver tip

I don't think it's a short on the front panel, because it will just keep running until I shut it off by holding the power button. I've submitted an RMA but this is going to cost me some money, even though I bought it 11 months and 20 days ago :'(

i only mention it cos its a new case and that the last thing you said was hitting the reset switch, ive had this happen to me before and in my case the reset button broke and was constantly closed, the machine would be on but do nothing and in my case the pwr switch also still turned the pc on and off.

Had something similar happen. Plug in the HDD LED in to the reset connector. took for ever to figure out.

Remove everything from the case. And do an open air ( everything on a table ) test with just the minimum components. But it sounds like ESD may have damaged the board.

thing is I had the pc running for exactly 24 hours (no joke) before it crashed when updating splinter cell. I should add that I had just installed the MSI stuff and it had supposedly updated the bios (liveupdate and whatnot) prior to updating splinter cell.