Pc build wont post/boot - fans spinning [solved]

Ok so i have an AMD FX8320, Hyper 212 evo cooler, Asus M5A97-R2 Motherboard, Amd R9 280X graphics card, 8gb of G.skill ares ram, and a Corsair Vs650 power supply... 
so i put in the cpu, ram and graphics card, wired it up, and it wont post. ive tried clearing cmos, different ram configurations, reseating and replugging everything i can... can someone help me cause this is my first build and im at a loss... 

Grab the latest BIOS from the ASUS website and use the BIOS flashback utility. See if that helps.

Ive already done that. It flashed but it didnt help

Hang in there Dgleeson198 I may have a solution.  Give me about 10 to 15 look through all your list. 


Exactly which ram did you get?  Can you link me?


is your ram F3-1600C9D-8GAO?

When ever you get back please post actual models.  I need to know your ram and psu.  I saw you have a psu listed but when I searched for it VX came up and VT.  

My thoughts on this was maybe the ram you bought isn't supported by the mother board that you have. It could be that your ram sticks were DOA and that could cause you not to boot. You have your video card?  Disconnect it and try to power it up that way and do this with ever part "NOT THE CPU".  But do this with your ram to, take one out and see if it posts, if not try all 4 slot of your mother board and see if that works. Is the mother board getting power? IE any lights?

i just went to buy a speaker but no beeps

ram is F3-1866C9D-8GAB 


there are lights on the motherboard, theres the green standby light, and if i try using the ramok feature it just flashes and does nothing

when using the memok button. you hold it till it starts blinking. it should load a fail safe config and reboot. if it still did not post you repeat the process. blinking should go faster telling you it is trying a different fail safe. can take a few tries. look for the cpu fan to slow and speed up telling you its rebooting-. i usually take everything out of the case to trouble shoot. hook up just the motherboard-cpu.ram-graphics card plus power to these. keep  the cpu heatsink and fan connected test and try the memok with just these. report back and we will try to help. good luck and stay positive

so i took it back to the shop i bough it from ( i got it delivered by post, cause its a three hour drive, and im 15 -_-) Got in and saw the technician and he worked out that the bios was corrupted, and reflashed it for me and now it posts/boots into bios. going to bed now cause im bone tired but i will re start my build tomorrow.