Return to Level1Techs.com

Passing throu nvidia gt610

kvm
qemu
#1

Hello,
I’m curious if there are any ways to debug why there is no output on my gt610 when I’ve passed it the same way i used to pass my RX460 *that worked out of box,

06:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 610] [10de:104a] (rev a1)
Subsystem: eVga.com. Corp. GF119 [GeForce GT 610] [3842:2615]
Kernel driver in use: vfio-pci
Kernel modules: nouveau
06:00.1 Audio device [0403]: NVIDIA Corporation GF119 HDMI Audio Controller [10de:0e08] (rev a1)
Subsystem: eVga.com. Corp. GF119 HDMI Audio Controller [3842:2615]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

as it seems its being binded by vfio but no display output for some reason, any help appreciated

0 Likes

#2

Wish I could help
I have the gt 520 Silent myself with the ASUS over clocking utility that was fun to play around with. Now it is more of a test tool I keep around just incase because it always works no matter what.

Zero help I know but atleast I can give ya a bump :slight_smile:

0 Likes

#3

If vfio-pci is built into your kernel version then you need to pass the device ID of the GPU as a kernel parameter. It needs to know which device to grab.

If you installed vfio-pci as a module, my guess is nouveau is loading first and grabbing the GPU before vfio-pci can get it. You must have all the module config entries for vfio-pci come before nouveau.

1 Like

#4

It’s being used as module, and I’ve blacklisted nouveau since my main gpu is using amdgpu,

throws this in log/libvirt/qemu/log
2019-06-25T20:08:28.242653Z qemu-system-x86_64: -device vfio-pci,host=06:00.0,id=hostdev0,bus=pci.3,addr=0x0: warning: vfio 0000:06:00.0: failed to setup resample irqfd: Invalid argument

0 Likes

#5

vfio is failing to setup the KVM subsystem properly.

What do you mean by blacklisted? Your output above shows the kernel module being loaded is nouveau. The driver in use and the module should be the same.

I don’t think you’ve configured the modules correctly. Maybe the advice on this thread will help?
Vfio-pci not working on nvidia gtx 960

0 Likes

#6

will this help, when i use display spice to get os there, in windows it shows error 10 and 12 (it detects but cant run(use))

0 Likes

#7

Hello, sorry for bumping the old topic up but am in trouble to make this working, I summon You Onii-chan @sgtawesomesauce :slight_smile: jokes aside, here is issue:

/etc/modprobe.d/vfio.conf -> options vfio-pci ids=10de:104a,10de:0e08

/etc/modules -> vfio
vfio_iommu_type1
vfio_pci
vfio_virqfd

/etc/mkinitcpio.conf -> MODULES=“vfio vfio_iommu_type1 vfio_pci vfio_virqfd amdgpu”

/etc/default/grub -> GRUB_CMDLINE_LINUX_DEFAULT=“quiet intel_iommu=on amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.dc=1”

inside /var/log/libvirt/qemu/ I get this

2019-07-11T17:59:44.033501Z qemu-system-x86_64: -device vfio-pci,host=06:00.0,id=hostdev0,bus=pci.6,addr=0x0: warning: vfio 0000:06:00.0: failed to setup resample irqfd: Invalid argument
2019-07-11T17:59:44.048928Z qemu-system-x86_64: -device vfio-pci,host=06:00.1,id=hostdev1,bus=pci.7,addr=0x0: warning: vfio 0000:06:00.1: failed to setup resample irqfd: Invalid argument
2019-07-11T17:59:45.080932Z qemu-system-x86_64: warning: vfio 0000:06:00.0: failed to setup resample irqfd: Invalid argument
2019-07-11T17:59:45.081065Z qemu-system-x86_64: warning: vfio 0000:06:00.1: failed to setup resample irqfd: Invalid argument

lspci -nnk

06:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 610] [10de:104a] (rev a1)
Subsystem: eVga.com. Corp. GF119 [GeForce GT 610] [3842:2615]
Kernel driver in use: vfio-pci
Kernel modules: nouveau
06:00.1 Audio device [0403]: NVIDIA Corporation GF119 HDMI Audio Controller [10de:0e08] (rev a1)
Subsystem: eVga.com. Corp. GF119 HDMI Audio Controller [3842:2615]
Kernel driver in use: vfio-pci
Kernel modules: snd_hda_intel

Assistance greatly appreciated, thanks in advance.

0 Likes

#8

I haven’t seen this one before. I’ll have to do some research.

Can you post your xml or params?

0 Likes

#9

here it is, different vm but its happening same all the time, not even turning monitor on ( i tried using virtual display to install drivers in windows but it gives error 10 and 12 in device manager)

xml i hope so

windows7 wm device manager pic

starting gpu-z gives bsod :stuck_out_tongue:

->sidenote win7 runs like segaemulator when u increase speed to x4

0 Likes