OVMF UEFI doesn't boot from SSD


I hope I chose the correct topic. My problem is the following: I followed the guide to passthrough a GPU on the ARCH Wiki. Everything worked perfectly fine. Finally I got to the point, where I had to create a Windows VM to pass the GPU to. The guide suggested a fresh installation of Windows on a virtual disk -> worked. But my Windows is on a physical SSD (/dev/sda). I’m able to boot with the block-device configured, but only in BIOS mode. As soon as I create the VM with the UEFI, provided by OVMF, I get the “UEFI-screen” (idk how to call it), it switches to a “shell” and I can type exit to get to the boot-menu in which i find my SSD. But clicking it doesn’t do anything. Nothing changes. No boot, no reaction at all.

Do you guys have an idea what this could be caused by that doesn’t involve creating a new VM with a virtual disk?

Thanks in advance. If you need configurations, etc., please tell me how to get to then, I’m not too familiar with Linux, yet!


So the windows installation on the SSD was installed on bare metal and not in a virtual machine?

Also, what windows version is this?

Thank you for your reply.

Windows was originally installed on bare metal but already ran in a virtual environment and works perfectly with BIOS.

Windows is running “Version 10.0.18363 Build 18363”

So it sounds to me as if your physical installation is on an MBR partition type. In order to do EFI boot it has to be a GPT partition and it has to have a FAT formatted EFI System Partition. Windows will also want its own little partition for various extras.


Thank you for your reply. And as always, it was the thing I assumed had to be and didn’t confirm.
Thank you 100% correct. Booted the System via BIOS changed it to GPT and booted with UEFI!

Tank you very much!