OVMF doesn't allow ISOs to boot

I’m using Debian 9, trying to install Windows in another VM with libvirt and OVMF.

Before, the UEFI wasn’t even recognising any storage as CDROM but I updated it to 20181115.085588389-3. Then it would recognise the medias as file systems but it just won’t boot. Either by the Manager or Command Line.

I’ve tried both Windows 10 and 8.1 (x64 versions). Windows 10 doesn’t do anything, but Windows 8.1 gives an error that makes me think that the UEFI is portraying itself as x86 and not x64.

And I tried changing from “cdrom” to hard drive…!

Help me, L1. You’re my only hope.

Have you tried booting a linux ISO?

Well, yes. My actual DVD (not ISO) with Debian 8 runs. And an ISO of Debian 10 also runs. To be honest, even the ISO from Windows 7 boots (it just can’t open the damn installer).

What makes me uncomfortable is that I used the same ISO (Win 8.1) to install another very similar VM last year, but since then I’ve updated my system to newer versions of everything. ):

Probably I should burn a DVD to test? This feels really weird.

Yah, that is weird.

Since it boots linux fine, I have no clue what the issue is.