Return to Level1Techs.com

Overclocking: A proposal for the next Linux Gaming part (also need some help)

#1

Personally , I think the theme of both parts published so far is pretty well documented on various websites. However, the information on overclocking is rather scarce. There are a few forum threads on reddit, couple articles and some wikis. Most of them have outdated, misleading info which sometimes conflicts with the info given on other websites.

First , you need to override the power feature by adding the amdgpu.ppfeaturemask=0xffffffff parametar to your boot parametars.
There is a command which can tell you whats your mask?, but WattmanGTK can do this for you. When i run “wattmanGTK” , it prints fffd7fff. After adding that to my grub, running “sudo update-grub2” and then rebooting i can’t boot into the system. The screen turns on/off a couple of times and then it says:“no signal”. Rebooting and removing those options from GRUB_CMDLINE_LINUX_DEFAULT helps.

As far as internet resources goes the most resourceful info i found was on the gentoo wiki but i can’t understand it. From what i can tell I need to add some firmware into the kernel, but i don’t know how do to that.
I tried following the arch wiki guide,as I have the same GPU, but that didn’t work.

Can somebody help me troubleshoot this, please ?

0 Likes

#2

I just use amdgpu.ppfeaturemask=0xffffffff and it works. Using a Sapphire RX480 Nitro+.

Your kernel needs to be newer that 4.17 and obviously a fully working driver. What distro are you using?

0 Likes

#3

Initially I tried it on Arch. Since I’m a Linux novice i thought I fucked up something during the setup. Then I went back and tried it on Kubuntu 19.04 and that didn’t work. Now I tried to just use the amdgpu.ppfeaturemask=0xffffffff on Manjaro with KDE and there is some progress. I can sometimes boot into the system but the screen goes either white or gray within 5mins.
Did you blacklist/add any modules in /etc/modprobe.d/ ?
A lot of guides mention adding options for amd Southern Islands (SI) and Sea Islands (CIK) support . Now, my card, like yours is Arctic Islands and support for them was added in kernel 4.7-rc6 . I don’t understand how adding those variables could work then and not now.

0 Likes

#4

No, no blackilisting or anything. Basically just added the parameter, ran update-grub and rebooted. Running Kubuntu 19.04 with 5.1.4 kernel. Did you try with the mask that wattmangtk prints for your card?

0 Likes

#5

Yes. Unfortunately it doesn’t work.
I went through the xorg log. There it apppers as everthing is going well. It recognizes the card and the vendor. The amdgpu driver gets loaded and the proper res is set .
There are no errors in the log.

0 Likes

#6

Can’t you just edit the bios of the gpu, and not to worry on the software side?

0 Likes

#7

Do you have a specific piece of software in mind?
Due to a digital signature requirement on latest AMD cards the development of most editors stopped.

0 Likes

#8

Update: After swapping the DP cable with a HDMI cable i got it to work(amdgpu.ppfeaturemask=0xfffd7fff).
Not sure why that is causing the issue.

0 Likes