Return to Level1Techs.com

Openshift DNS help (ndots?)

I changed something in my DNS and it half broke my openshift cluster and I’m not entirely sure what I did. You can take a look at one of the bugs I filed with Openshift to get some context, but basically, all the containers have ndots 5 in the /etc/resolv.conf by default. If I leave it at 5, and try to curl something like github dot com, it treats it like a local address and I get Openshift’s default “Application not available” message. When I change ndots to 1, everything works as expected. BUUUTTTTT, I can’t change the default dns options on things like builds so my builds always fail.

I am assuming this has something to do with my network config PLUS ndots = 5. Everything else on my network works fine, but they also have ndots = 1 (the default). I am running pihole as my DNS and unifi USG Pro 4 as my router, I can get you whatever options you need/want, but I don’t even know where to begin with this. I am definitely not a network guy…