OpenGL no Direct Render

New to linux. i have my graphic drivers installed 346.47. (i know some new ones came out yesterday)

I installed steam and i get this error, OpenGL GLX context is not using direct rendering, which may cause performance problems. umm im lost. tried looking up thinks on my own cant get anything to work.

tried this lib32-nvidia-libgl, but it says missing destination file. i dont know how to install something to a specific file or directory. Total noob that really needs some help.

curious, which nvidia gpu do you have?

sorry for leaving that out. ASUS STRIX GTX 970

Reinstall the graphic drivers by rerunning the 346.47 installation file, and the problem should go away.

So i have to uninstall drivers first. And then reinstall them. Can i get the command to uninstall my drivers? i know its 'sudo purge' something

What distro are you running and how did you install the drivers (sometimes the process is different).. Though uninstalling it all and then USE the nvidia binary provided here.

make sure you do this from a TTY window and kill the xerver and DM.. its a sure fire way to do it error free ..

Then blacklist nouveau (this is the process for Ubuntu 14.04)
After you finish with this one, you should also blacklist the nouveau driver by editing this file with either:
gksudo gedit /etc/modprobe.d/blacklist-nouveau.conf
sudo nano /etc/modprobe.d/blacklist-nouveau.conf

Regardless of edit mode
…and add these lines at the end:

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

I am running ubuntu 14.10 and i installed my drivers by killing the xserver and then running the commands to install my drivers from my downloads file from the tty. But i never blacklisted nouveau.

Blacklisting Nouveau will help with your issue because .. the nouveau openGL library conflicts with the lib32-nvidia-libgl...
Also just noticed the 32.
have you implemented multiarch support?

Try running this command
sudo apt-get build-dep multiarch ##this builds the dependcies for multiarch
Sudo ap-get install multiarch ## this grabs the package

If you want to use 32 bit software on a 64 bit system you need multiarch compiling and kernel support...

Blacklisting nouveau is always good idea.. since nouveau can be stubborn... ( that being said BACK UP your previous conf... so when you update the kernel or distro you can revert back and install the latest nvidia drivers...)

As I said earlier, you don't have to do anything other than to rerun the drivers installation file. You don't have to remove the drivers.