Open-Razer not working on PopOS (Razer Kraken 7.1 v2)

Hello everyone, I’ve been watching the channel for a while now but I’m new to the forum.

I’ve been using Linux for more than 6 years now and I’m quite comfortable with it (although I’m no expert, I just have a basic understanding on how things work and can deal with most stuff on my own), I’ve used Gentoo for a year and mostly Ubuntu and Ubuntu Studio, I’ve recently built a nice Desktop PC and moved to PopOS since then.

About month ago I’ve bought a pair of Razer Kraken 7.1 headphones, not that great but really good for the price (and I actually had them for half the price with a discount).

Mostly for curiosity and not actually for necessity, I tried installing open-razer.

It was fairly standard and easy and everything seemed to be ok, I followed the official guide like I would normally do.

However, the daemon doesn’t recognize my headphones at all. They’re perfectly working out of the box, but openrazer doesn’t find them.

So I followed the official guide and did everything that needed to be done.

Now, here’s where things get weird. I’ve added my user to the correct groups, I’ve even tried with different - but equivalent - commands, but the daemon still tells me I’m not part of that group.

Here’s some useful output:

sudo usermod -aG plugdev giorgio [sudo] password for giorgio: ~ took 3s

➜ openrazer-daemon Unable to lock on the pidfile.

And yet my user actually IS in the right groups.

➜ cat /etc/group | grep audio audio:x:29:pulse,giorgio ~ ➜ cat /etc/group | grep plugdev plugdev:x:46:giorgio

Any idea on what could be wrong? It might be something very stupid and obvious I’m missing

After you add yourself to a new supplementary group you need to logout and log back in or reboot and login because the running user shell will not pick up on the new modifications automatically.

I knew this, that’s the first thing I did, but the problem persists after logging out or rebooting.
The weird thing is that my user is in that group

can you verify that by running group. Not that I don’t believe you but that is another way to check the the user is in the right groups by having he system report.

I don’t know why this would matter, but according to their instructions, if you see the pidfile error, you need to add your user to the plugdev group like this, `sudo gpasswd -a $USER plugdev and then reboot. And every reference I see people saying use the above and not the standard usermod method.

I can confirm I did as instructed by the troubleshooting guide and rebooted, I also tried with other methods just in case gpasswd was somehow broken. I can also confirm with groups that my user is in plugdev (even though, I don’t see how the cat command should be wrong, as /etc/group is the right file).
At this point I’m not really sure what I should do…

Yeah, I figured that they are the same but because everything called out that specific method… could not hurt.

I would imagine that possibly there could be a udev issue that needs a rule in place to ensure that the group actually has access to that device.

OR there is something else that needs to be done with PopOS because… Ubuntu.

What’s so wrong with Ubuntu?

They do things differently than the other GNu/Linux distros. Mainly config files, default locations, and their own spin on some technologies. It is a good starter OS, but can kind of hamstring you if only deal with Ubuntu and then have to deal with a non ubuntu based linux.